Manque ODBC pour Access 2003 sous Vista [Résolu]

Messages postés
20
Date d'inscription
mardi 13 mai 2008
Statut
Membre
Dernière intervention
21 août 2009
- - Dernière réponse : DenisPhil
Messages postés
20
Date d'inscription
mardi 13 mai 2008
Statut
Membre
Dernière intervention
21 août 2009
- 21 août 2009 à 13:21
Bonjour à tous,
sur un PC sous XP, j'ai un prog Delphi qui utilise une base de données Access (MS Access 2003). Tout fonctionne bien...
Sur un autre PC sous Vista, j'ai installé le source Delphi du prog, je l'ai compilé, j'ai (enfin, je crois) déclaré ma base dans [Panneau de conf] + [Outils Adm] + [Sources de données ODBC] et j'ai tenté de l'exécuter...
mais j'ai un message d'erreur :
[Microsoft][Gestionnaire de pilote ODBC] Source de données introuvable et nom de pilote non spécifié
.

Sur les deux PC (un en XP, l'autre en Vista), la même version de MS Office 2003 est installée.
Est-ce encore un des pb de compatibilité de Vista ?
Où pourrais-je trouver ce pilote ODBC Access qui parait manquer ?
Merci de vos réponses.
Denis
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
4716
Date d'inscription
dimanche 26 février 2006
Statut
Modérateur
Dernière intervention
27 mars 2018
11
3
Merci
bonsoir,
Il y a, bien sûr, l'ultime solution : foutre Vista à la poubelle et installer XP à la place

bonne pioche !

cantador

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 137 internautes nous ont dit merci ce mois-ci

Commenter la réponse de cs_cantador
Messages postés
20
Date d'inscription
mardi 13 mai 2008
Statut
Membre
Dernière intervention
21 août 2009
0
Merci
Bonjour,
ça n'est pas une réponse mais une question...
Il n'y a personne pour me donner un conseil sur le sujet ?

Il y a, bien sûr, l'ultime solution : foutre Vista à la poubelle et installer XP à la place mais c'est un peu brutal et je ne sais pas si le HD du PC n'est pas gravé pour Vista...
Merci de votre aide.
Denis
Commenter la réponse de DenisPhil
Messages postés
20
Date d'inscription
mardi 13 mai 2008
Statut
Membre
Dernière intervention
21 août 2009
0
Merci
Bonjour,
après beaucoup d'essais et de modifs, j'ai réussi à faire fonctionner la base access avec mon prog Delphi.
Il suffisait (?) de déclarer la base dans le [panneau de conf] + [Outils d'administration] + [sources de données ODBC] en utilisant, dans le champs "nom de la source de données" le même nom que celui de la base...
Donc, mon pb est résolu... sans changer de système. Ouf !

Merci à tous.
Commenter la réponse de DenisPhil