Affichage du preload des sons d'une anim ???

cs_proffy Messages postés 13 Date d'inscription vendredi 30 mai 2003 Statut Membre Dernière intervention 26 août 2006 - 6 juin 2003 à 11:20
cs_proffy Messages postés 13 Date d'inscription vendredi 30 mai 2003 Statut Membre Dernière intervention 26 août 2006 - 6 juin 2003 à 16:28
Bon voila, mon intro marche toujours pas, mais maintenant je sais pkoi !!!

le probleme est ke c pas l'anim (le preloader) ki charge les sons mais internet explorer !
alors la barre de chargement ne s'affiche ke kan les sons sont chargés, c'est a dire apartir de 90 % !

donc klk1 saurait komment fR apparaitre le chargement des sons svp ?????

pour l'instant, mon code de preload est ca:

onClipEvent(enterFrame) {
_root.stop();
total = _root.getBytesTotal();
chargé = _root.getBytesLoaded();
pourcent = Math.floor(chargé/total*100);
this.loadBar._width = pourcent*1.5;
this.charge.text = "Chargement... " + pourcent + " %"
if (pourcent >= 99) {
_root.nextFrame();
}
}

Merci d'avance

Warty Proffy

[mailto:BenjaminKuperberg111@hotmail.com mailto:BenjaminKuperberg111@hotmail.com]

2 réponses

cs_tom Messages postés 1511 Date d'inscription samedi 8 décembre 2001 Statut Modérateur Dernière intervention 11 juin 2009
6 juin 2003 à 14:53
Salut, je suppose que tes sons sont attachés ou commencent à la premiere image... Tu peux aussi avoir des clips qui prennent du poids, puisqu'il faut les charger completement pour qu'ils s'affichent.
J'utilise le test de l'animation avec affichage de la bande passante pour récupérer le poids de la premiere image. Je clique sur l'image1 de la bande passante: un poids s'affiche sur le coté, il correspond à ce qu'il faut charger pour que ca commence.

Apres pour vérifier, tu as juste à faire un truc du genre:

if((chargé/1024)>le_poids_de_la_premiere_image){
this.charge.text += "Prêt à partir!";
}

@+ Tom
0
cs_proffy Messages postés 13 Date d'inscription vendredi 30 mai 2003 Statut Membre Dernière intervention 26 août 2006
6 juin 2003 à 16:28
oki merci c sympa
...mais g reussi avec loadSound, c plus simple ;o)

[mailto:BenjaminKuperberg111@hotmail.com mailto:BenjaminKuperberg111@hotmail.com]
0