Problème avec textures

Signaler
Messages postés
29
Date d'inscription
samedi 11 mars 2006
Statut
Membre
Dernière intervention
13 décembre 2011
-
Messages postés
3874
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
7 novembre 2014
-
Salut à tous!

Je vous explique mon problème, j'essaie (en vain) d'appliquer des textures en OpenGL avec DevCpp à l'aide du site du zéro.
Problème, je lance mon programme, qui fonctionne, j'ajoute l'include sdlglutils.h comme indiqué sur le site. Et je déclare GLuint identifiant_texture = loadTexture("ROCK.bmp"), par la suite.

Et là ça coince!   Erreurs : [Linker error] undefined reference to `loadTexture(char const*, bool)'
                                        [Linker error] undefined reference to `WinMain@16'

Qu'est ce que je peux faire? Est ce que je n'ai pas les bons Linker?

Merci à tous

27 réponses

Messages postés
29
Date d'inscription
samedi 11 mars 2006
Statut
Membre
Dernière intervention
13 décembre 2011

Merci pour ces liens, je vais me pencher dessus ce soir
GLScene semble plus qu'intéressant!

J'ai tenté le test de la message box, et elle ne s'affiche même pas, donc ça plante avant le main...
Je suis dans le brouillard Je comprends pas!
Messages postés
29
Date d'inscription
samedi 11 mars 2006
Statut
Membre
Dernière intervention
13 décembre 2011

Merci beaucoup pour ton aide en tous cas!

Je suis finalement passé sous Builder pour tout réaliser, je ne sais pas du tout comment utiliser GLscene avec, par contre... J'ouvrirai (encore) un post au pire!
Messages postés
29
Date d'inscription
samedi 11 mars 2006
Statut
Membre
Dernière intervention
13 décembre 2011

Est ce que tu sais comment utiliser Glscene sous Builder? J'ai trouvé sur plusieurs forums qu'il n'y aurait pas moyens!
Messages postés
3874
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
7 novembre 2014
14
Ah oui pardon j'ai foiré mon lien plus haut. Regarde ici.

Heu... Accessoirement, si tu n'es pas un Dieu du C++, tu peux te tourner vers Delphi, nettement plus simple, aussi performant, et tout à fait compatible GLScene. Tu peux télécharger Delphi 7 ici.
Messages postés
29
Date d'inscription
samedi 11 mars 2006
Statut
Membre
Dernière intervention
13 décembre 2011

Je me disais bine qu'il y avait un problème de lien! Je vais essayer ça.

En ce qui concerne Delphi, j'en ai fais il y a un petit moment, mais je suis assez adepte du C/C++, ça fait un moment que je l'utilise, mais c'est la première fois que je fais de la 3D par contre!
Messages postés
29
Date d'inscription
samedi 11 mars 2006
Statut
Membre
Dernière intervention
13 décembre 2011

Est ce que tu connais un autre moyen d'installer Glscene sous builder? Ici je ne peux pas installer de logiciels, je n'ai pas les droits... Et vu qu'il faut CVS (je n'arrive même pas à le télécharger en plus^^)...
Messages postés
3874
Date d'inscription
mardi 8 mars 2005
Statut
Modérateur
Dernière intervention
7 novembre 2014
14
Plutôt que d'utiliser CVS avec un client en ligne de commande, la FAQ propose d'utiliser tortoise CVS (En 1.8), un outil qui s'intègre à l'explorateur windows, téléchargeable ici.

Il ne te reste qu'à l'installer chez toi, faire ce que te demande la FAQ, faire une archive et la mettre sur clé usb...

Tu peux avoir plus d'infos sur CVS et le source de GLScene ici.