Problème sur ScrollPane et MovieClip

Signaler
Messages postés
7
Date d'inscription
mardi 17 décembre 2002
Statut
Membre
Dernière intervention
17 juin 2005
-
Messages postés
2
Date d'inscription
vendredi 4 novembre 2005
Statut
Membre
Dernière intervention
20 novembre 2005
-
Bonjour,

J'ai créé un ScrollPane depuis un "Flash UI Components" et lui ai associé un contenu de type MovieClip. Jusque là, rien d'anormal.

Seulement, ce MovieClip (appelons-le "Vignette"), est entièrement défini par des scripts lui demandant de dessiner un empilement de n carrés nommés de telle manière qu'il sont ensuite associés à des images 'externes' à l'application par la fonction "loadMovie".

En d'autres termes, il s'agit d'un scrolling de vignettes comme on l'en rencontre dans la plupart des albums photos.

Seulement, mon MovieClip "Vignette" ne peut-être visualisé dans mon composant qu'à la condition suivante ; lui ajouter un objet - quel qu'il soit - même transparent.

Malheureusement, mon ScrollPane prend justement cet élément en considération pour calculer la hauteur du MovieClip associé ! Et redimensionner l'élement ne change en rien cet état.

Bref, quelqu'un a-t'il rencontré ce problème et, si possible, aurait une solution à me suggérer ?

Merci d'avance pour votre aide, bien à tous,

Serge RAPPAILLE

3 réponses

Messages postés
7
Date d'inscription
mardi 20 mai 2003
Statut
Membre
Dernière intervention
30 mai 2005

Salut !

j'ai exactement le même problème, j'inclue dans un scrollpane un swf
qui ne contient que des MC générés dynamiquement, et quand le contenu
de ce swf dépasse la taille de mon scrollpane, les barres de défilement
n'apparaissent pas ...

ce qui est plutôt embêtant



donc si quelqu'un a une solution, je suis preneur :-p
Messages postés
7
Date d'inscription
mardi 20 mai 2003
Statut
Membre
Dernière intervention
30 mai 2005

personne ne s'est jamais trouvé face à ce cas de figure ?
Messages postés
2
Date d'inscription
vendredi 4 novembre 2005
Statut
Membre
Dernière intervention
20 novembre 2005

Bin moi, si ! J'ai eu le mème problème. Mais en utilisant l'instruction :
mon_clip.refreshPane(); une ou deux images après le chargement, la barre réapparait.