Problème lecteur vidéo avec MciSendString sous Vista par contre OK sous XP

Signaler
Messages postés
2
Date d'inscription
dimanche 15 juin 2008
Statut
Membre
Dernière intervention
27 juin 2009
-
Messages postés
15
Date d'inscription
samedi 14 août 2004
Statut
Membre
Dernière intervention
24 août 2009
-
Bonjour,


J’ai réalisé un lecteur vidéo tout simple (en VB6 – sources trouvées sur vbfrance) pour lire des vidéos au format AVI (720x576 pal), ce lecteur fonctionne très bien sous XP, les images sont désentrelacées, par contre sous Vista lorsque la vidéo bouge les images sont entrelacées.


Le lecteur utilise la fonction MciSendString.



<?xml:namespace prefix o ns "urn:schemas-microsoft-com:office:office" /??>
 




Les essais réalisés pour solutionner ce défaut



1)      mise à jour de Vista (non)



2)      lancement de l’exe en mode administrateur sous Vista (non)



3)      modification des paramètres de la carte graphique NVIDIA 9200 sous Vista (non)



4)      recherche d’une option  pour désentrelacer la vidéo avec MciSendString (pas trouvé)



5)      lecture des vidéos AVI avec Windows MédiaPlayer (OK sur Vista)



6)      lecture avec VLC (OK sur Vista avec un filtre  de désentrelacement – bob)



 




Conclusion :


La fonction MciSendString pose un problème avec Vista, pourquoi ?



 




Si vous pouviez me fournir d’autres pistes pour solutionner ce problème, un grand merci d’avance.



 A+

2 réponses

Messages postés
2
Date d'inscription
dimanche 15 juin 2008
Statut
Membre
Dernière intervention
27 juin 2009

Messages postés
15
Date d'inscription
samedi 14 août 2004
Statut
Membre
Dernière intervention
24 août 2009

MCIsendstring ne pose pas de probléme avec vista
J'ai eu ce genre de probléme et celà est uniquement lié au rapport width et height de la frame ou de la picturebox cible qui n'est pas correctement réglé (si chnagement de taille)
Voilà en espérant vous avoir aidé

Cheta