Requete xpath dans fichier xsd

Résolu
mastereur
Messages postés
37
Date d'inscription
jeudi 17 mai 2007
Statut
Membre
Dernière intervention
26 décembre 2010
- 20 mai 2009 à 14:10
mastereur
Messages postés
37
Date d'inscription
jeudi 17 mai 2007
Statut
Membre
Dernière intervention
26 décembre 2010
- 20 mai 2009 à 17:18
Bonjour,

j'ai un petit  problème: je souhaite effectuer une requête xpath dans un fichier xsd  (//xs:element[@name= 'typeEquipement']//xs:enumeration) afin de récupérer une valeur.
Seulement l'exception XpathException est soulever, dans l'aide msdn, cela m'indique xslt machinchose.

Pourtant ma requete xpath est correct (je vérifie avec le log XPathBuilder).

Comment puis-je y remédier?

Merci d'avance!

3 réponses

mastereur
Messages postés
37
Date d'inscription
jeudi 17 mai 2007
Statut
Membre
Dernière intervention
26 décembre 2010

20 mai 2009 à 17:18
Bon en fait, je me suis totalement gouré

la soluce:
http://msdn.microsoft.com/fr-fr/library/e5t11tzt.aspx
3
mastereur
Messages postés
37
Date d'inscription
jeudi 17 mai 2007
Statut
Membre
Dernière intervention
26 décembre 2010

20 mai 2009 à 14:31
J'ai trouvé, il s'agissait d'espace de  nom (j'en apprends de jour en jour)

le requête xpath deviens donc
//element[@name= 'typeEquipement']//enumeration
0
mastereur
Messages postés
37
Date d'inscription
jeudi 17 mai 2007
Statut
Membre
Dernière intervention
26 décembre 2010

20 mai 2009 à 14:32
Oups petite erreur de ma part
/element[@name= 'typeEquipement']/enumeration
0