Zend Jquery Ajax | probleme d'affichege d'element sous IE [Résolu]

Signaler
Messages postés
30
Date d'inscription
jeudi 14 mai 2009
Statut
Membre
Dernière intervention
11 février 2011
-
Messages postés
30
Date d'inscription
jeudi 14 mai 2009
Statut
Membre
Dernière intervention
11 février 2011
-
Bonjour,
j'ai developpé une application Zend sous wamp.
Pour différents formulaires, j'utilise JQuery pour executer des requetes ajax afin d'afficher un tableau d'aide à la saisie en fonction du champ en focus.

En local tout fonctionne sous FF et IE.

Mon problème est le suivant :
j'ai transféré mon application sur un windows server 2003 possédant apache php et mysql pour une mise en production. Les tableaux d'aide à la saisie s'affiche toujours sous FF/Opéra/Chrome mais plus sous IE.

j'ai contrôlé que les ActiveX et plugins soient bien activés, modifier mes requêtes JQuery mais rien n'y fait sous IE mes tableaux ne s'affiche pas voilà mon code JQuery pour l'appel des tableaux

$("input#Types_clients_id").focus(function(){
$.ajax({
url:"/CentreDeLavage/Fichier/infotypesclients",
type: "POST",
success:function(msg){
$("div#aide").append(msg);
}
});
});
$("input#Types_clients_id").blur(function(){
$.ajax({
type: "POST",
success:function(msg){
$("div#aide").empty();
}
});
});


Un appel simple de javascript fonctionne il s'agit vraiment de la partie ajax.

Quelqu'un a-t-il déjà eu le problème ou aurait-il une solution?

1 réponse

Messages postés
30
Date d'inscription
jeudi 14 mai 2009
Statut
Membre
Dernière intervention
11 février 2011