Rotation texte probleme

Résolu
coreangel
Messages postés
13
Date d'inscription
mercredi 29 avril 2009
Statut
Membre
Dernière intervention
15 mai 2009
- 14 mai 2009 à 13:24
coreangel
Messages postés
13
Date d'inscription
mercredi 29 avril 2009
Statut
Membre
Dernière intervention
15 mai 2009
- 15 mai 2009 à 18:41
bonjour a tous
dans mon anime j appel un texte depuis un fichier txt mise en forme par un css qui s affiche dans un textfield
voici mon code
................................................................................
TextField("texte");
with (texte) {
 selectable = false;
 html = true;
 multiline = true;
 wordWrap = true;
 }
var lv = new LoadVars();
lv.onLoad = function() {
 texte.htmlText = lv["texte"];
 
};
var ss = new TextField.StyleSheet();
ss.onLoad = function() {
 texte.styleSheet = ss;
 lv.load("texte.txt");
};
ss.load("styles.css");
............................................................................
mon souci c d que je met mon textfield incliner de environ 30° (sur l image ) mon texte n apparait plus
g essayer d integrai la police (comics sans ms) mais rien y fais
comment dois je faire pour que mon texte apparaise?
merci d avance

11 réponses

cs_ourso
Messages postés
92
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
5 décembre 2010

15 mai 2009 à 13:30
si ta chaine est un copier coller de ton script alors c'est un peu normal que ça ne marche pas
1/ remplace les guillemets par des apostrophes
2/ mets plutôt target que "traget"
Steph
3/ mets ta chaine entre guillemets

ça donne ça :
chaine="[event.html evenements]

";
3
cs_ourso
Messages postés
92
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
5 décembre 2010

15 mai 2009 à 13:31
chaine="evenements

";
3
cs_ourso
Messages postés
92
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
5 décembre 2010

15 mai 2009 à 13:34
PS: sans oublier le param. embedFonts=true; sinon ton texte disparaitràa avec la rotation
3
cs_ourso
Messages postés
92
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
5 décembre 2010

15 mai 2009 à 14:52
En principe tu le mets en même temps que la declaration de ton champ texte... Si ça ne marche pas c'est que flash ne loade pas les contours de ta police. Il me semble à ce propos que "comic..." fait partie des typos systême. Il y a donc une possibilité pour que flash ne passe pas par la typo de ta bibliothèque mais par son sytème par défaut. Pour ma part je ne voit pas comment t'aider plus... Maintenant que tu as la typo qui s'affiche... un petit tour sur les forums, un peu de bidouille, et tu devrais trouver ce qui ne va pas.
Bonne journée
3

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
cs_ourso
Messages postés
92
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
5 décembre 2010

15 mai 2009 à 01:10
integre ta police dans l'appli puis sur ton champ texte "embedFonts=true"

Steph
0
coreangel
Messages postés
13
Date d'inscription
mercredi 29 avril 2009
Statut
Membre
Dernière intervention
15 mai 2009

15 mai 2009 à 12:38
merci ourso mais g deja essayer cette methode mais sans succes
peu importe l endroit (dans le code) ou je place "embedfonts=true" mon texte disparait totalement
si quelqu un aurai une autre soluce ou me dire comment bien integrer une police (possible que je l intergre mal, j suis debutant en flash)
se serai sympas
merci d avance
0
cs_ourso
Messages postés
92
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
5 décembre 2010

15 mai 2009 à 12:42
Alors il se pourrait que tu te soit emmelé les pinceaux dans ta CSS... elle donne quoi cette feuille de style ? Et le texte qui vient s'integrer il se présente comment ?
Steph
0
coreangel
Messages postés
13
Date d'inscription
mercredi 29 avril 2009
Statut
Membre
Dernière intervention
15 mai 2009

15 mai 2009 à 12:56
mon css et mon texte sont assez simple
voici le css
.......................................
.titre{
 font-family:"Comic Sans MS", cursive;
 font-size:50px;
 text-align:center;
 font-style:italic;
 color: #ff0000;
}
.........................................
et mon texte
.........................................
texte=[event.html evenements]

.......................................
voila si sa peu vous aider a me dire ou est le bug je vous en remerci
0
coreangel
Messages postés
13
Date d'inscription
mercredi 29 avril 2009
Statut
Membre
Dernière intervention
15 mai 2009

15 mai 2009 à 14:01
g effectuer les modif que tu ma conseiller mais pourrai tu me dire ou mettre le param embedFonts=true; 
g essayer de le placer peu importe la ligne ou je le mets dans mon as rien y fait mon texte disparai toujour avec la rotation
0
vegetalain
Messages postés
747
Date d'inscription
mardi 25 mars 2003
Statut
Membre
Dernière intervention
11 août 2022

15 mai 2009 à 15:30
Hm... perso j'ai pu incliné une police avec juste la sélection "Texte bitmap (sans anti-alias)", puis dans "intégrer" en fait, j'ia mis ça : azertyuiopqsdfghjklmwxcvbnAZERTYUIOPQSDFGHJKLMWXCVBN123456789çàâéêè@/.,;:?!()'
Le texte est chargé depuis un xml et ça roule... le truce est non seulement incliné mais il tourne selon la souris, avec "._rotation" !....
Rien d'autre.
0
coreangel
Messages postés
13
Date d'inscription
mercredi 29 avril 2009
Statut
Membre
Dernière intervention
15 mai 2009

15 mai 2009 à 18:41
merci ourso de ton aide
c etait mon fichier css qui posser probleme je l ai suppr et sa marche
merci a tous
0