Formulaire flash sous IE7 provoque une erreur inconnue... [Résolu]

Messages postés
1511
Date d'inscription
samedi 8 décembre 2001
Statut
Modérateur
Dernière intervention
11 juin 2009
- - Dernière réponse : cs_tom
Messages postés
1511
Date d'inscription
samedi 8 décembre 2001
Statut
Modérateur
Dernière intervention
11 juin 2009
- 14 mai 2009 à 11:58
Bonjour,

J'ai reçu un site à débugger, et là je tombe sur le probleme le plus bizarre qu'il m'ai été de rencontrer avec flash :

c'est un site en as2 qui utilise beaucoup de loadmovie. Tant qu'on navigue dans le site, tout va bien...

Mais le moment où on télécharge un document, on fait appel à un php qui force le download, en lui envoyant une variable (j'ai essayé avec GET et POST, en getURL ou en loadvars.send, ça donne toujours le meme résultat qui suit) :
Une fois que l'on a fait ça, on peut se déplacer à nouveau sur le site, il me balance un message d'erreur à chaque loadmovie en ces termes précis :
"Internet Explorer ne peut télécharger .

Erreur non spécifiée"

Quelqu'un aurait une piste? Je dois dire que je commence à secher là... :/
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
1204
Date d'inscription
lundi 10 mars 2003
Statut
Membre
Dernière intervention
23 juillet 2009
2
3
Merci
Salut,

plutot que de passer par un php pour le download, tu devrais esayer le FileReference.download()

Avantages :
* pas d'appel a un php
* Possibilité de suivre la progression du téléchargement
* Notification de début, fin de téléchargement
* Notification en cas d'erreurs...

@+

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 207 internautes nous ont dit merci ce mois-ci

Commenter la réponse de cs_Girou
Messages postés
1511
Date d'inscription
samedi 8 décembre 2001
Statut
Modérateur
Dernière intervention
11 juin 2009
0
Merci
Merci de ta reponse, je vais voir ça tout de suite
Commenter la réponse de cs_tom
Messages postés
1511
Date d'inscription
samedi 8 décembre 2001
Statut
Modérateur
Dernière intervention
11 juin 2009
0
Merci
Ca m'a permis de contourner le probleme de post. Ca va pas m'aider à ne plus etre en froid avec IE, mais au moins adobe a apporté des solutions à ce probleme.
Commenter la réponse de cs_tom