Problème integration applet sur jsp avec WTP (Class not found) [Résolu]

Signaler
Messages postés
2
Date d'inscription
dimanche 13 mars 2005
Statut
Membre
Dernière intervention
10 avril 2009
-
alioujigga
Messages postés
2
Date d'inscription
lundi 15 juin 2009
Statut
Membre
Dernière intervention
13 mars 2012
-
Bonjour,

J'essaie éperdument mais sans succès d'intégrer une applet à une page JSP sur une application web dynamique. Cette dernière est réalisée avec eclipse et le module WTP.

 
 

J'ai cette balise dans ma jsp située à la racine du dossier webcontent, de même que le fichier CourseApplet.class mais j'ai malgré tout l'erreur suivante.

java.lang.ClassNotFoundException: CourseApplet
    at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
    at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)
Caused by: java.io.IOException: open HTTP connection failed:http://localhost:8080/testAppletWeb/CourseApplet.class
    at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
    at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
    at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    ... 7 more

J'ai tout essayé pour ce qui est des liens, à savoir déplacé le fichier .class a peu près partout, utilisé la balise "archive" avec ma classe dans un .jar. Le fait est que l'applet marche très bien intégrée tout bêtement à une page html en dehors du projet, mais une fois dedans c'est à désespérer.

Aidez moi !!!

2 réponses

Messages postés
2
Date d'inscription
dimanche 13 mars 2005
Statut
Membre
Dernière intervention
10 avril 2009

Je pouvais toujours chercher :


J'ai changer le numéro de port (8080) utilisé par Oracle et le problème
est résolu. Certaines subtilités m'échappent mais ca marche !
Messages postés
2
Date d'inscription
lundi 15 juin 2009
Statut
Membre
Dernière intervention
13 mars 2012

Bonjour,

Je sais que le poste date mais là j'ai le même problème que toi...
Est-ce que tu pourrais m'expliquer

...J'ai changer le numéro de port (8080) utilisé par Oracle et le problème est résolu. Certaines subtilités m'échappent mais ca marche !...


Merci!