Enregister dans ma base

Signaler
Messages postés
48
Date d'inscription
lundi 23 février 2009
Statut
Membre
Dernière intervention
30 avril 2009
-
Messages postés
433
Date d'inscription
samedi 26 avril 2003
Statut
Membre
Dernière intervention
4 décembre 2009
-
Salut;
dans mon forme j'ai un bouton qui permet de créer un label et un richbox.

if (indice <25)
{
this._currentHeight += 40;
this._currentHeig += 40;

RichTextBox tx = new RichTextBox();
tx.Size = new System.Drawing.Size(599, 34);
tx.Location = new Point(100, this._currentHeight);
tx.Name = tab[indice];
rich[indice] = tx;
Label l = new Label();
l.Size = new System.Drawing.Size(40, 40);
l.Location = new Point(30, this._currentHeig);
l.Name = tab[indice];
l.Text = tab[indice];
label[i] = l;
button1.Click += new EventHandler(tx_GotFocus);
panel2.Controls.Add(l);
panel2.Controls.Add(tx);
indice++;

}
je souhaite d'enrregister le text du richbox dans ma base.
j'ai crée un tableau richBox[] rich=new richBox[25];
pour récupèrer dans la base je fait:
com.Parameters.Add("@desrep", OleDbType.Char).Value = rich[0].Text;
com.Parameters.Add("@desrep", OleDbType.Char).Value = rich[1].Text;
com.Parameters.Add("@desrep", OleDbType.Char).Value = rich[3].Text;
.
.
.
MAIS aucun texte n'est enregistré dans la base .
S.V.P pouvez vous m'aider pour résoudre ce cette erreur.

1 réponse

Messages postés
433
Date d'inscription
samedi 26 avril 2003
Statut
Membre
Dernière intervention
4 décembre 2009
1
Bonjour,

Attention, tu envois la valeur d'une variable nommée "rich" mais ton textbox que tu cree se nomme "tx". Il y aurait il un bout de code qui manque ?