Cfmail

Signaler
-
 Rastafa -
Bonjour a tous

pour commencer, je suis content de pouvoir enfin m'expliquer dans ma langue natale que je maitrise un peu mieux que l'anglois profond

bon, j'ai deja harcele allaire concernant mon probleme : je tourne sous cf 4.5, sous nt4 sp6, avec tous les patchs possibles concernant cf
mon probleme, bien que referencé (et soi-disant patché) chez allaire, concerne le cfmail
En effet, je peux declencher un CFMAIL sans aucun probleme, mais si par hasard je declenche 2 CFMAIL dans la meme page, donc tres rapproches, mon cfserver part en sucette, et occupe toute les ressources du serveur (quoi toutes, 99/100 ;) ). Les mails restent dans le dossier mail/spool/ du serveur, et j'ai l'impression qu'il ya qque chose qui boucle, et qui est tres gourmand en plus. De plus, les logs ne me parlent pas de ce probleme.

J'ai appliqué le patch corrigeant soi-disant les problemes de cfmail, sans aucun resultat positifs...J'ai egalement teste l'augmentation de la valeur "delay" dans la registry (que rajoute un des patchs, d'ailleurs), et meme en mettant des valeurs astronomiques, le resultat reste le meme...

Personne n'aurait une idee ?

Merci d'avance.
A voir également:

4 réponses

Je ne connais pas la réponse à ton problème, mais tu pourrais essayer CF_ADVANCEDEMAIL que tu peux retrouver à cette adresse :
http://vandieten.net/jochem/coldfusion/customtags/advancedemail/

Peut-être que ca va règler ton problème...
Rastafa
Copy paste du site de allaire:
This tag is a crutch to the recent CFMAIL problems in the new 4.5 server. Using this tag you can get e-mail messages that couldn't be sent due to unknown cfmail errors, convert them to a cfmail 4.0 format, and send them using a 4.0 server. If you schedule this tag it can provide a quick fix until allaire relaeases a 4.5.1 update.

http://devex.allaire.com/developer/gallery/info.cfm?ObjectID=14502&method=full

Bebye
vivi, effectivement c'est une solution, mais je n'ai aucun acces a la machine de developpement, ou se produit ce probleme, et donc installer une version 4.0 m'est impossible (et je trouve ca limite, aussi)...et refuse par la personne responsable de cette machine
De plus, mon probleme ne se produit que sur la version pro, mais pas sur la version entreprise...et comme sur le seveur de dev, nous avons la pro, et sur le serveur reel, l'entreprise, je prefere attendre un nouveau patch qui corrigera cela.

Merci pour tout
Salut,
J'ai eu un problème de CFMAIL aujourd'huis et j'ai pensé à toi. J'envoyais un reply à un client qui avait remplie un formulaire X. Par ex.:
<CFMAIL TO="#courriel#" FROM="info@lenomdudomaine.com" SUJECT="Tout est OK">

Le reply ne marchait pas. La raison est que la demande pour le nom de domaine du site internet n'était pas encore fait. Donc, ce que je pense, c'est quand ColdFusion trouve pas le dns du serveur de mail, il en send pas le mail.

Ex.:
<CFMAIL TO="luc@12mmm.com" FROM="abc@yahoo.com" SUJECT="Tout est OK">

Ceci ne marchera pas car ColdFustion ne trouve pas le DNS de 12mmm.com

Pareille pour:
<CFMAIL TO="luc@hotmail.com" FROM="abcyahoo.com" SUJECT="Tout est OK">

Il n'y a pas de @ dans le email du FROM, donc ColdFusion ne va pas envoyer le mail...

Jèspère que ca va pouvoir t'aider
Salut
(Et si quelqu'un c comment désactiver ca du serveur , dites-moi le !)
Rastafa