AIDE : Probleme avec la variable $_SERVER["LOGON_USER"]

Signaler
Messages postés
2
Date d'inscription
jeudi 27 novembre 2008
Statut
Membre
Dernière intervention
25 mars 2009
-
Messages postés
150
Date d'inscription
samedi 8 avril 2006
Statut
Membre
Dernière intervention
1 mai 2012
-
Bonjour à Tous et merci par avance de l'aide que vous allez m'apporter.

Cela fait maintenant plusieurs jours que je lutte contre la variable $_SERVER["LOGON_USER"].
Voila ce que je souahite faire, recuperer l'identifiant de la session windows pour par la suite afficher tel ou tel menu.
J'en suis toujours à la 1ere partie qui est de recuperer l'identifiant windows.
D'après ce que j'ai vu il faut utiliser la variable $_SERVER["LOGON_USER"], mais cette variable ne me retourne rien (test effectuer avec la commande echo) et quand je fait print_r($_SERVER) je ne la vois pas.

Je suis arrivé à un stade ou je desespere completement et je ne sais plus quoi faire.

Pour information je suis sur un seveur WAMP 2.0, et je me connecte depuis un poste en WinXP.
Si vous voulez plus de détail n'hésiter pas à demander.

1 réponse

Messages postés
150
Date d'inscription
samedi 8 avril 2006
Statut
Membre
Dernière intervention
1 mai 2012
2
Tu ne peux pas récupérer le nom de la session windows en php, qui est un langage s'executant côté serveur (chez ton hébergeur) et non pas côté client (chez le visiteur). Ce serait peut-être possible en javascript mais je suis pas sûr et si oui je sais pas comment faire ...

A+

Antho 25
------------------------------------
Rien n'empêche Melba