Problème d'apostrophe sur site complexe

Signaler
Messages postés
2
Date d'inscription
mardi 3 mars 2009
Statut
Membre
Dernière intervention
25 mars 2009
-
Messages postés
2
Date d'inscription
mardi 3 mars 2009
Statut
Membre
Dernière intervention
25 mars 2009
-
Bonjour,

Je deviens dingue... Je débute en PHP et je souhaite, du coup, corriger un bug dans ma liste de films en ligne (créée avec PhpMyDVDs).

Le système utilisé est un peu vieux, mais je n'ai pas trouvé d'équivalent aussi complet et personnalisable. Le seul problème de ce système est qu'il bug dès qu'un titre contient un apostrophe (').

J'ai essayé de glisser des stripslashes un peu partout, d'ajouter des codes, rien n'y fait.

Quelqu'un pourrait m'aider en me disant si c'est possible d'améliorer le système ?

Source du système :
http://oldportal.phpmydvds.org/

Ou alors, si quelqu'un connaît un autre code customisable dans lequel recommencer ma liste qui contienne au moins les champs suivants : Titre(s), réalisateur, acteurs, durée, affiche, support, catégorie.

Merci beaucoup de votre aide.

2 réponses

Messages postés
681
Date d'inscription
samedi 26 février 2005
Statut
Membre
Dernière intervention
21 août 2014
7
Bonjour!!

Il je ne connais pas le script, et ne peut pas vraiment le regarder - manque de temps -
une solution "bricolée" serait de remplacer l'apostrophe par son code ASCII ( 39 ) dès la réception des donnés, avant l'insertion dans la base....

la fonction str_replace() fera l'affaire... a condition que tu sache où l'utiliser:

l'entité HTML pour le code ASCII 39 est ' il faudrait donc remplacer toutes les apostrophes par ça ^^
Bonne chance!

<hr size="2" width="100%" />Some Geek: Tous les programmeurs sont des brutes, [...] ils violent chaque ligne, chaque language [...] et n'on aucun goût pour la beauté de ./sh

Pysco68:
Messages postés
2
Date d'inscription
mardi 3 mars 2009
Statut
Membre
Dernière intervention
25 mars 2009

Salut et merci pour cette astuce.

Je vais voir comment je peux intégrer ça aux scripts existants.