Problème avec CDONTS

Signaler
Messages postés
16
Date d'inscription
samedi 28 décembre 2002
Statut
Membre
Dernière intervention
21 octobre 2010
-
Messages postés
3983
Date d'inscription
jeudi 14 juillet 2005
Statut
Membre
Dernière intervention
30 juin 2013
-
Salut
j'ai un problème avec cdonts. J'utilise le script suivant :

<% Dim Mailer


Set Mailer=Server.CreateObject("CDONTS.NewMail")


Mailer.To=[mailto:adresse@domaine.fr adresse@domaine.fr]
Mailer.From=[mailto:adresse2@domaine2.fr adresse2@domaine2.fr]
Mailer.Subject="Titre"
Mailer.Body="corps du message"
Mailer.Send




Set Mailer=Nothing %>

Lorsque je lance le script, la page s'affiche bien, tout semble fonctionner mais le mail ne parvient pas au destinataire. Quels controles effectuer pour trouver d'ou vient l'erreur ??

Ma config :
serveur Win2000 serveur, service SMTP activé et configuré par défaut.

Voila, merci pour votre aide...@+

4 réponses

Messages postés
3983
Date d'inscription
jeudi 14 juillet 2005
Statut
Membre
Dernière intervention
30 juin 2013
14
Mailer.To= [mailto:adresse@domaine.fr " adresse@domaine.fr]"
Mailer.From =[mailto:adresse2@domaine2.fr ]"adresse2@domaine2.fr[mailto:adresse@domaine.fr "]
Messages postés
16
Date d'inscription
samedi 28 décembre 2002
Statut
Membre
Dernière intervention
21 octobre 2010

ok, je vais essayer....

Merci!!!
@+

tazegue
Messages postés
3983
Date d'inscription
jeudi 14 juillet 2005
Statut
Membre
Dernière intervention
30 juin 2013
14
Et y'a de fortes chances que ton provider interdise d'envoyer les mails soi-même.
Donc va dans le gestionnaire IIS -> Clic-droit sur SMTP -> Propriétés.

Dans "Smart Host" tu mets l'adresse du SMTP de ton provider.
Et ensuite appliquer, OK, appliquer, OK.
Messages postés
3983
Date d'inscription
jeudi 14 juillet 2005
Statut
Membre
Dernière intervention
30 juin 2013
14
Oups j'aurais voulu la mettre transparente ...