Connexion a une base de données distante avec Delphi

cs_nassim25 Messages postés 3 Date d'inscription samedi 28 mai 2005 Statut Membre Dernière intervention 20 février 2009 - 20 févr. 2009 à 18:59
aek2009 Messages postés 3 Date d'inscription lundi 4 mai 2009 Statut Membre Dernière intervention 20 octobre 2012 - 12 août 2009 à 23:07
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="ProgId" content="Word.Document" />
<meta name="Generator" content="Microsoft Word 11" />
<meta name="Originator" content="Microsoft Word 11" />
<link rel="File-List" href="file:///C:%5CDOCUME%7E1%5CADMINI%7E1%5CLOCALS%7E1%5CTemp%5Cmsohtml1%5C01%5Cclip_filelist.xml" />
<!--[if gte mso 9]><xml>
<w:WordDocument>
<w:View>Normal</w:View>
<w:Zoom>0</w:Zoom>
<w:PunctuationKerning/>
<w:ValidateAgainstSchemas/>
<w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid>
<w:IgnoreMixedContent>false</w:IgnoreMixedContent>
<w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText>
<w:Compatibility>
<w:BreakWrappedTables/>
<w:SnapToGridInCell/>
<w:WrapTextWithPunct/>
<w:UseAsianBreakRules/>
<w:DontGrowAutofit/>
</w:Compatibility>
<w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel>
</w:WordDocument>
</xml><![endif]-->
<!--[if gte mso 9]><xml>
<w:LatentStyles DefLockedState="false" LatentStyleCount="156">
</w:LatentStyles>
</xml><![endif]-->
<style>
<!--
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
{mso-style-parent:"";
margin:0cm;
margin-bottom:.0001pt;
text-align:right;
mso-pagination:widow-orphan;
direction:rtl;
unicode-bidi:embed;
font-size:12.0pt;
font-family:"Times New Roman";
mso-fareast-font-family:"Times New Roman";}
@page Section1
{size:612.0pt 792.0pt;
margin:70.85pt 70.85pt 70.85pt 70.85pt;
mso-header-margin:36.0pt;
mso-footer-margin:36.0pt;
mso-paper-source:0;}
div.Section1
{page:Section1;}
-->
</style>
<!--[if gte mso 10]>
<style>
/* Style Definitions */
table.MsoNormalTable
{mso-style-name:"Tableau Normal";
mso-tstyle-rowband-size:0;
mso-tstyle-colband-size:0;
mso-style-noshow:yes;
mso-style-parent:"";
mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
mso-para-margin:0cm;
mso-para-margin-bottom:.0001pt;
mso-pagination:widow-orphan;
font-size:10.0pt;
font-family:"Times New Roman";
mso-ansi-language:#0400;
mso-fareast-language:#0400;
mso-bidi-language:#0400;}
</style>
<![endif]-->
Je voudriez savoir comment quel objet utilisé
pour pouvoir ce connecter a une base de données SQL serveur 2000 avec Delphi sachons
que  
la base et sur une serveur (Windows serveur 2003

4 réponses

cs_magic84 Messages postés 37 Date d'inscription samedi 24 janvier 2009 Statut Membre Dernière intervention 6 avril 2014
22 févr. 2009 à 14:00
salut nassim .j'ai le méme probléme que toi ,concernant la connexion a une base de donnée sql server 2000.tu peut utliser la connexion ado ou bien la connexion interbase .mais comment le faire ?moi méme J'attend des réponses...
bonne chance
0
peacemonde Messages postés 1 Date d'inscription vendredi 19 décembre 2008 Statut Membre Dernière intervention 30 juillet 2009
30 juil. 2009 à 23:15
0
cs_cantador Messages postés 4720 Date d'inscription dimanche 26 février 2006 Statut Modérateur Dernière intervention 31 juillet 2021 14
31 juil. 2009 à 15:25
bonjour,

Il faut installer le driver ODBC sql server 2000
et se connecter comme avec access ou paradox.

A moins toutefois qu'il existe des composants spécifiques sql server 2000 ?

cantador
0
aek2009 Messages postés 3 Date d'inscription lundi 4 mai 2009 Statut Membre Dernière intervention 20 octobre 2012
12 août 2009 à 23:07
AEK
- L'onglet fournisseur de ado connexion choisissez (MS OLE Prov for SQL Server).
- L'onglet connexion selectionez le serveur, et la bdd sur le serveur, et tester la connexion.
0