Netstream.seek cesse de fonctionner une fois en ligne!

simflint Messages postés 2 Date d'inscription vendredi 28 novembre 2008 Statut Membre Dernière intervention 30 janvier 2009 - 30 janv. 2009 à 07:11
simflint Messages postés 2 Date d'inscription vendredi 28 novembre 2008 Statut Membre Dernière intervention 30 janvier 2009 - 30 janv. 2009 à 15:15
Bonjour!

J'ai une vidéo que je fais jouer avec flash CS3 (action script 2) et ce en streaming. J'ai ajouter un netstream.seek(10) pour commander le début du vidéo à 10 seconde.

Alors voici que ça fonctionne impec en local... mais une fois sur le serveur, la vidéo part du début...

J'ai beau chercher, je ne comprend pas! Quelqu'un peut-il m'expliquer?

en attendant je galère!

2 réponses

Orange73 Messages postés 1375 Date d'inscription dimanche 28 novembre 2004 Statut Membre Dernière intervention 2 août 2011
30 janv. 2009 à 13:33
Sans code on peut pas t'aider :)
0
simflint Messages postés 2 Date d'inscription vendredi 28 novembre 2008 Statut Membre Dernière intervention 30 janvier 2009
30 janv. 2009 à 15:15
Le voici :

var netConn:NetConnection = new NetConnection();
netConn.connect(null);
var Stream:NetStream = new NetStream(netConn);
maVideo.attachVideo(Stream);
Stream.setBufferTime(2);
Stream.play("lefichier.flv");
Stream.seek(10);

Je répète qu'en local tout est parfait... Mais une fois sur le serveur, le streaming est établie sans problème, mais la commande seek est ignorée et le vidéo commence du début.

C'est vrai que c'est plus clair comme ça! excusez-moi!
0