Probleme lecture fichier SWF + XML sur internet [Résolu]

Messages postés
3
Date d'inscription
vendredi 17 janvier 2003
Statut
Membre
Dernière intervention
29 janvier 2009
- - Dernière réponse : mathieu77186
Messages postés
3
Date d'inscription
vendredi 17 janvier 2003
Statut
Membre
Dernière intervention
29 janvier 2009
- 29 janv. 2009 à 20:15
Bonjour,

Je dois mettre en ligne un site internet très simple contenant une banniere flash.

Il s'agit d'une animation de type slideshow dans laquelle les images sont gérés via un fichier xml.

Lorsque je test mon application en tapant directement le nom du fichier.swf , cela fonctionne par contre dès que j'essaie de l'inclure dans une page web, l'animation ne se lance pas (page blanche).

Ce qui est étrange c'est que lorsque j'essaie de lire un fichier .swf sans xml; cela fonctionne dans la page web sans aucun probleme.

Est ce que cela vient du fait qu'il ya de l'AS dans mon flash ??? ou du fait du XML ???

Je suis donc complètement bloqué ...

Merci d'avance pour votre aide !

Mathieu
Afficher la suite 

6 réponses

Meilleure réponse
Messages postés
1381
Date d'inscription
samedi 9 octobre 2004
Statut
Membre
Dernière intervention
1 novembre 2010
3
Merci
J'ai répondu à un post dans le même genre il y a quelques jours. Recherche dans les derniers posts du forum tu le trouveras.
Ton problème viens d'un mauvais appel de tes fichiers sources lorsque tu les envoies en distants.

bali_balo....=]

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 198 internautes nous ont dit merci ce mois-ci

Commenter la réponse de cs_bali_balo
Messages postés
3
Date d'inscription
vendredi 17 janvier 2003
Statut
Membre
Dernière intervention
29 janvier 2009
3
Merci
Bonsoir,

J'ai finalement trouvé la solution à mon problème...
Il s'agissait du lien vers le fichier xml.
Bref j'ai tout mis à la racine et ca marche très bien.

Merci pour ton aide bali balo ;)
Bonne soirée

Mathieu

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 198 internautes nous ont dit merci ce mois-ci

Commenter la réponse de mathieu77186
Messages postés
3
Date d'inscription
vendredi 17 janvier 2003
Statut
Membre
Dernière intervention
29 janvier 2009
0
Merci
Bosnoir,
Je suis désolé mais je n'ais pas trouvé dans vos post une solution à mon problème ...

Merci d'avance pour votre aide :)

Mathieu
Commenter la réponse de mathieu77186
Messages postés
2
Date d'inscription
vendredi 1 décembre 2006
Statut
Membre
Dernière intervention
28 janvier 2009
0
Merci
Bonjour Mathieu, j'ai exactement le même soucis que toi, le fichier swf fonctionne bien mais quand je l'utilise dans une page html impossible de voir les images, les textes chargés dynamiquement eux fonctionnents...
voici la page : http://www.codasystem.com/fr/pages/produits_mobiles-compatibles.htm
swf qui fonctionne bien seul : http://www.codasystem.com/choix_mobiles/choix_marques_coverflow.swf

J'ai utilisé le coverflow d'apple créé par un gars et j'ai rajouté des zones textes que j'avais besoin, un ami à qui j'ai envoyé le script du flash (car il y a 2 flash un premier avec le menu qui charge un autre swf suivant la marque qu'on a choisi dans le menu) m'as dis que le soucis pouvait venir du fait que le script du coverflow n'avait pas été créé à la base pour être chargé dans un second flash et donc que les images chargées dynamiquement sont appellées qu'avec des liens this et donc j'ai beau donné les liens en dur dans mes xml, les images ne veulent pas se charger. Ce qui est bizarre c'est que si le fait que le coverflow n'était pas prévu pour charger des images en dur, pourquoi tout fonctionne quand le swf avec le menu qui charge le coverflow d'une des marques fonctionne quand il n'est pas chargé dans une page html ? ça ne pourrait pas venir d'un script dans la page html qui bloque le chargement ou qui change la racine ou ajoute quelque chose par sécurité à mes liens des images ?
Bref je suis bloqué là je suis deg on va devoir repasser a un truc plus statique et moche :(.

Si quelqu'un à une idée je suis prenneur...
Commenter la réponse de helfspawn
Messages postés
1381
Date d'inscription
samedi 9 octobre 2004
Statut
Membre
Dernière intervention
1 novembre 2010
Commenter la réponse de cs_bali_balo
Messages postés
2
Date d'inscription
vendredi 1 décembre 2006
Statut
Membre
Dernière intervention
28 janvier 2009
0
Merci
Merci du lien mais entre temps j'ai trouvé ou modifier la racine des fichiers images dans le second flash, le gars avait prévu qu'on puisse changer la racine de là ou l'on va chercher les photos ouf :)

Donc pour moi sujet clos :)
Commenter la réponse de helfspawn