Pb déploiement application winform cible .NET 2.0 setup généré par VS2008

cs_wodan Messages postés 5 Date d'inscription mercredi 16 avril 2003 Statut Membre Dernière intervention 21 janvier 2009 - 19 janv. 2009 à 18:24
cs_wodan Messages postés 5 Date d'inscription mercredi 16 avril 2003 Statut Membre Dernière intervention 21 janvier 2009 - 20 janv. 2009 à 09:52
Bonjour,

j'ai un soucis lorsque je déploie mon application winform avec le framework .NET 2.0 pour cible.

J'ai créé un projet de déploiement dans VS2008 avec pour dépendance la version 2.0.50727 du framework.
Les projets de ma solution associée à ce projet de déploiement ont également pour cible le framework 2.0.
L'ensemble de mes dll de références sur mes différents projets correspodent à la version du runtime 2.0.50727.

OR lorsque je lance le Setup de mon projet de déploiement il me demande d'installer le framework 3.5 !!!!
Je n'y comprend plus rien.

si quelqu'un a une idée elle sera la bienvenue.

Merci d'avance

Cordialement

Wodan

3 réponses

cs_bellak Messages postés 136 Date d'inscription jeudi 27 décembre 2007 Statut Membre Dernière intervention 5 mai 2011
19 janv. 2009 à 19:02
Salut ,
as-tu verifier le Framework cible de ton projet ?? sinon verifie les composants requis de ton projet de deploiement
0
cs_wodan Messages postés 5 Date d'inscription mercredi 16 avril 2003 Statut Membre Dernière intervention 21 janvier 2009
19 janv. 2009 à 21:59
Oui c'est la première chose que j'ai faite puis comme je l'ai dit dans mon message celle du projet de déploiement aussi (je suis même allé voir dans le fichier vdproj il y a un passage qui dit :

"LaunchCondition"
            {
                "{A06ECF26-33A3-4562-8140-9B0E340D4F24}:_A8649432E48F456B8FC173FB4C375285"
                {
                "Name" = "8:.NET Framework"
                "Message" = "8:[VSDNETMSG]"
                "Version" = "8: 2.0.50727 "
                "AllowLaterVersions" = "11:FALSE"
                "InstallUrl" = "8:http://go.microsoft.com/fwlink/?LinkId=76617"
                }
            }
on y voit clairement le 2.0.50727 !!!

Les composants requis pour le projet de déploiement sont repris du projet que l'on déploie automatiquement dans "dépendance détectées" du vdproj.
Là que des composants nécessitant le 2.0 pour tourner.
0
cs_wodan Messages postés 5 Date d'inscription mercredi 16 avril 2003 Statut Membre Dernière intervention 21 janvier 2009
20 janv. 2009 à 09:52
J'ai repris ma solution sur VS2005 (sln et csproj à modifier un peu dans ce sens ça n'est pas automatique !!!)
et j'ai régénéré mon setup et là... no problem il me demande bien en prérequis le framework .NET 2.0 et pas le 3.5.

Quelqu'un a-t-il entendu parlé d'un soucis avec VS2008 sur le sujet ?

Merci pour vos réponse
0