Problème d'envoie de mail

fanzy76 Messages postés 8 Date d'inscription vendredi 18 juillet 2008 Statut Membre Dernière intervention 2 mars 2009 - 16 janv. 2009 à 15:30
Teclis01 Messages postés 1423 Date d'inscription mardi 14 décembre 2004 Statut Membre Dernière intervention 29 décembre 2012 - 16 janv. 2009 à 17:28
Bonjour,

J'ai un problème dont je n'arrive pas à trouver l'origine.
Je suis en cours de création d'un site. Tous les formulaires en PHP retournent les données par envoie de mail.
J'utilise la fonction mail() pour l'envoie.

En local, pas de problèmes pour la reception, en revanche, sur le serveur distant, aucun mail n'est recptionné.
PHP certifie pourtant l'envoie du mail en renvoyant TRUE.

Pour cela, je fais un :
if(mail(...))
{
   echo "Mail envoyé";
}

Quelqu'un aurait-il déjà eu à faire à ce même genre de problème?
Ou aurait une idée de comment le résoudre?
Ne serait-ce même qu'une piste?
Parce que là je bloque et je ne vois pas pour commencer mes vérifications (surtout quand tout fonctionne impec en local!).

Merci d'avance

3 réponses

Teclis01 Messages postés 1423 Date d'inscription mardi 14 décembre 2004 Statut Membre Dernière intervention 29 décembre 2012 4
16 janv. 2009 à 15:38
Oui. Tu as un serveur mail installé sur ton serveur distant ? Si non commence par là!

Il vaut mieux poser une question et passer pour bête que le rester toute sa vie

Les geeks n'ont pas une case en moins ils commencent juste à compter à partir de zéro
0
fanzy76 Messages postés 8 Date d'inscription vendredi 18 juillet 2008 Statut Membre Dernière intervention 2 mars 2009
16 janv. 2009 à 16:18
Merci pour cette information.

J'ai fait quelques recherches sur la toile. Et j'ai vu que (mon hébergeur étant infomaniak), que la fonction mail de php n'était tout simplement pas activée par mesure de sécurité.

Si vous rencontrez des problèmes de ce genre, contactez votre hébergeur, il sera vous renseigner.

Des heures de recherches et d'incompréhension juste pour cela!
Dur dur d'être développeur!

Merci encore Teclis01 pour tes réponses aussi rapides
0
Teclis01 Messages postés 1423 Date d'inscription mardi 14 décembre 2004 Statut Membre Dernière intervention 29 décembre 2012 4
16 janv. 2009 à 17:28
Niarf ça c'est balot... Plus qu'a changer d'hébergeur >_<
C'est ça aussi d'être dev' ... Malheureusement!

Il vaut mieux poser une question et passer pour bête que le rester toute sa vie

Les geeks n'ont pas une case en moins ils commencent juste à compter à partir de zéro
0