Animation flash via ActionScript [Résolu]

Signaler
Messages postés
2
Date d'inscription
mardi 8 juillet 2003
Statut
Membre
Dernière intervention
14 janvier 2009
-
Messages postés
2
Date d'inscription
mardi 8 juillet 2003
Statut
Membre
Dernière intervention
14 janvier 2009
-
Bonjour,

    Voilà je débute en flash et je bloque sur un problème. Je souhaite faire un quizz où les questions sont présentés par un personnage. J'ai crée un MovieClip avec différente animation pour mon personnage, dont une où ses levres bougent et une autre où il se mets en colere. J'ai crée un code AS avec une fonction pour chaque action, j'ai donc une fonction Parle qui fait un gotoandPlay sur le début de l'animation parle et une fonction colere qui fait un gotoAndPlay sur mon anim colere. Jusque là tout va bien, sauf que lorsque je veux appeler ces fonctions depuis le clip principale ça ne marche pas, mon personnage n'exquisse aucun mouvement.

   Est ce que quelqu'un aurait une idée sur ce qui ne pourrait pas marcher ????

  Si je n'ai pas été assez clair, dites le moi

Merci d'avance

Frederic

2 réponses

Messages postés
2
Date d'inscription
mardi 8 juillet 2003
Statut
Membre
Dernière intervention
14 janvier 2009

Slt,

   Merci, mais en faite j'ai compris l'origine de mon problème ce matin. Le problème c'est moi
A force d'avoir le nez dessus je ne l'avais pas vu. J'ai du mal à me faire au faite que Flash soit sensible à la casse du coup j'avais pas mis la même syntaxe pour l'appel de ma fonction, trop nul le gars... Désolé pour le dérangement

Frederic
Messages postés
1132
Date d'inscription
mercredi 28 août 2002
Statut
Membre
Dernière intervention
6 mars 2020
1
Slt,

Peux tu nous donner la partie de code qui conrrespond ou nous donner ton fla afin que l'on cible mieux ton problème.

Bàt,
Burnside.

..:: Enjoy living in hell ::..
http://www.art-line.be