Mail() ne fonctionne pas! [Résolu]

Messages postés
843
Date d'inscription
mercredi 22 octobre 2003
Dernière intervention
7 janvier 2009
- 4 janv. 2009 à 01:51 - Dernière réponse :
Messages postés
5
Date d'inscription
dimanche 17 août 2008
Dernière intervention
22 octobre 2009
- 26 juin 2009 à 00:27
Bonsoir,
Question mainte fois posé (constaté après une recherche Google), mais impossible de trouver une réponse correcte pouvant m'aider. Alors avant d'écrire à l'hébergeur (que vous ne connaissez pas, c'est une petite boîte régionale en Suisse), je m'adresse à vous...

J'utilise donc la fonction mail(), celle-ci me renvoie 1, mais aucun mail n'arrive dans ma boite.

mail('kevin.ory@swissonline.ch', 'Sujet!', 'Du texte...', 'From: raeblus@swissonline.ch') ;

Voici un extrait de phpinfo de valeur que je pense pouvoir être utile (Local Value = Master Value):

sendmail_from        no value                   
sendmail_path        /usr/sbin/sendmail -t -i  
SMTP                 localhost                 
smtp_port            25                         

Quelqu'un peut-il me dire ou je dois chercher pour résoudre ce problème?

Merci d'avance!
Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
Messages postés
149
Date d'inscription
lundi 7 février 2005
Dernière intervention
6 février 2009
5 janv. 2009 à 17:38
3
Merci
Salut,
a mon avis ton envoi de mail fonctionne mais ton serveur mail doit le prendre pour un spam.

Il faut rajouter les en-têtes qui vont bien dans l'adresse de l'expéditeur pour que ton serveur l'accepte:

$From  = "From: raeblus@swissonline.ch \n";
$From .= "MIME-version: 1.0 \n";
$From .= "Content-type: text/html; charset= iso-8859-1 \n";

mail('kevin.ory@swissonline.ch', 'Sujet!', 'Du texte...', $From)

Voilou essaie ca

Merci krolenain 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 90 internautes ce mois-ci

Commenter la réponse de krolenain
Meilleure réponse
Messages postés
843
Date d'inscription
mercredi 22 octobre 2003
Dernière intervention
7 janvier 2009
7 janv. 2009 à 03:48
3
Merci
Eh bien non, ça n'a rien a voir avec ce que j'ai dis dans le message précédent....

Fonctionne:
mail('
accounts.ory@swissonline.ch', 'Sujet!', '
Du texte...', 'From: homepage@raeblus.ch') ;
mail('accounts.ory@swissonline.ch', 'Sujet!', 'Du texte...', 'From: homepage@dfgdfgsd.ch') ;
mail('accounts.ory@swissonline.ch', 'Sujet!', 'Du texte...', 'From: homepage@hotmail.com') ;
mail('kyro2882@hotmail.com', 'Sujet!', 'Du texte...', 'From: homepage@hotmail.com') ;

mail(
'kyro2882@hotmail.com', 'Sujet!', 'Du texte...', 'From: homepage@swissonline.ch') ;

Ne fonctionne pas:
mail(
'accounts.ory@swissonline.ch', 'Sujet!', 'Du texte...', 'From: homepage@swissonline.ch') ;

A rien n'y comprendre... la seule solution qui ne fonctionne pas est lorsque l'expéditeur et la destination ont une adresse swissonline.ch (pourtant ça fonctionne avec hotmail.com)... Si qqun à une explication, je suis preneur!

Je dois dire que ça m'étonne de ne jamais avoir essayé de changer l'adresse de l'expéditeur, mais bon, c'est pas impossible....

Je viens de relire mon message précédent, solution qui sois disant aurait du fonctionner.... mais ce n'est pas le cas, le domaine de l'expéditeur et de la destination est justement swissonline.ch... bah je comprend plus rien, j'ai sans doute fais une faute en transcrivant la solution

Le principal, c'est que maintenant ça fonctionne

Merci Kevin.Ory 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 90 internautes ce mois-ci

Commenter la réponse de Kevin.Ory
Messages postés
7
Date d'inscription
vendredi 2 janvier 2009
Dernière intervention
9 mars 2009
4 janv. 2009 à 09:27
0
Merci
Bonjour,
je débute seulement alors je peux te donner mon code qui fonctionne mais la partie phpinfo je peux pas t'aider
$destinataire="adresse du destinataire";
$sujet="retour questionnaire";
$contenu="texte de contenu du mail";
mail($destinataire,$sujet,$contenu);
voilà bon courage
Commenter la réponse de chlipou
Messages postés
843
Date d'inscription
mercredi 22 octobre 2003
Dernière intervention
7 janvier 2009
4 janv. 2009 à 18:01
0
Merci
Merci pour ta réponse, mais je fais bien ça, à part que j'utilise des ' au lieu des " (ce qui vient au même) et que j'ajoute un en-tête pour spécifier la boite d'envoi...

Mais ça ne fonctionne pas
Commenter la réponse de Kevin.Ory
Messages postés
843
Date d'inscription
mercredi 22 octobre 2003
Dernière intervention
7 janvier 2009
6 janv. 2009 à 19:05
0
Merci
Avec ton code, ça ne fonctionnait toujours pas. Mais comme ton idée de compléter l'en-tête  me semblait quand même très pertinente, j'ai cherché dans ce sens, et...... ceci fonctionne:

$headers = "From: raeblus@swissonline.ch\r\n" .
                'X-Mailer: PHP/' . phpversion() . "\r\n" .
                "MIME-Version: 1.0\r\n" .
                "Content-Type: text/html; charset=utf-8\r\n" .
                "Content-Transfer-Encoding: 8bit\r\n\r\n";
   
mail('kevin.ory@swissonline.ch', 'Sujet!', 'Du texte...', $headers);

Je ne sais pas encore ce qui a fait la différence (le \r probablement), mais maintenant que je reçois qq chose dans ma boite je vais enfin pouvoir avancer. Je m'y met de suite...

Merci pour ton aide, et bonne continuation
Commenter la réponse de Kevin.Ory
Messages postés
5
Date d'inscription
dimanche 17 août 2008
Dernière intervention
22 octobre 2009
26 juin 2009 à 00:27
0
Merci
Bonjour à tous ;

mais j'ai rencontré un problème :

Warning: mail() [function.mail]:
Failed to connect to mailserver at "localhost" port 25, verify your
"SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\wamp\www\teste\email.php on line 5

je sais pas comment configurer mon php.ini  aidezmoi

merci d'avance
Commenter la réponse de ayoubationp

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.