Probleme avec AtlAxCreateControl

Signaler
Messages postés
653
Date d'inscription
mardi 6 décembre 2005
Statut
Membre
Dernière intervention
10 novembre 2014
-
Messages postés
653
Date d'inscription
mardi 6 décembre 2005
Statut
Membre
Dernière intervention
10 novembre 2014
-
Salut a tous,
Je suis en train de faire un prog pour lire des playlist de Deezer, pour ca j'utilise AtlAxCreateControl de cette facon:
AtlAxCreateControl(L"MSHTML:<Code Html>", hwnd, 0, &lpContainer);
Ca marche niquel sauf que ca me rajoute une bordure(

) tout autour de mon code: http://img141.imageshack.us/img141/7465/deezermz7.png
Quelqu'un pourrais m'expliquer comment m'en débarrasser?

Neo_Fr

2 réponses

Messages postés
123
Date d'inscription
samedi 14 juillet 2007
Statut
Membre
Dernière intervention
29 mars 2009
1
C'est normal, c'est le default border HTML, il suffit de l'enlever
C'est une FAQ Win32. Voir sur le ng pro des apis Win32 :
news://fr.comp.os.ms-windows.programmation
où cela a été maintes fois discuté
(et pas besoin de l'artillerie ATL pour l'ActiveX hosting, puisque c'est natif en Win32 avec le built-in control OCX Host...)
Messages postés
653
Date d'inscription
mardi 6 décembre 2005
Statut
Membre
Dernière intervention
10 novembre 2014
2
"C'est normal, c'est le default border HTML, il suffit de l'enlever"
Oui mais comment?

"et pas besoin de l'artillerie ATL..."
T'inquiete pas je n'utile pas atl, seulement une fonction que je charge directement depuis la dll...

"c'est natif en Win32 avec le built-in control OCX Host"
J'ai cherché sur msdn mais j'ai absolument rien trouvé sur ce controle

Neo_Fr