Probleme validation xhtml strict : attribut "name" [Résolu]

Signaler
Messages postés
8
Date d'inscription
dimanche 19 septembre 2004
Statut
Membre
Dernière intervention
3 janvier 2009
-
Messages postés
8
Date d'inscription
dimanche 19 septembre 2004
Statut
Membre
Dernière intervention
3 janvier 2009
-
Bonjour à tous,
j'ai crée mon serveur et j'ai commencé à faire un site dessus.
J'ai choisi xhtml 1.1 dans visual studio, j'ai changé le xhtmlconformance en strict dans le webconfig.

Lorsque je test le site en interne : ca marche super, validation OK.

Je l'ai donc mit sur le serveur, fait une belle redirection avec dyndns.org et hourra mon site (en construction ^^) est sur internet !

Le problème : lorsque je veux valider le site en xhtml 1.1 : 2 erreurs :

attribut name interdit :
<form name= " aspnetForm" method ="post" action="default.aspx" id="aspnetForm">

je ne sais pas pourquoi il y a l'attribut name en plus que l'id est déjà présent et que j'ai normalement tout fait pour éviter ca.

2ème erreur :
une erreur bizarre sur le ">" à la fin du viewstate.

Je ne sais pas comment résoudre le problème. En xhtml 1.0 transitionnal ca marche bien mais j'aurai quand même voulu le faire en xhtml 1.1.

Si quelqu'un a une idée ...
Voila l'adresse de mon site :

http://ezvie.dyndns.org

Merci d'avance.

1 réponse

Messages postés
8
Date d'inscription
dimanche 19 septembre 2004
Statut
Membre
Dernière intervention
3 janvier 2009

J'ai trouvé la solution :
si quelqu'un a le même problème, il suffit de suivre les conseils donnés sur cette page :

http://wiki.lessthandot.com/index.php/ASP.NET:_XHTML_Strict_Validation