Problème d'un fichier .xml pas lu par mon .swf online

Résolu
Noiro588 Messages postés 3 Date d'inscription mercredi 23 mai 2007 Statut Membre Dernière intervention 21 décembre 2008 - 20 déc. 2008 à 13:11
Noiro588 Messages postés 3 Date d'inscription mercredi 23 mai 2007 Statut Membre Dernière intervention 21 décembre 2008 - 21 déc. 2008 à 00:30
Bonjour le forum,

En fait j'ai un petit problème sur un fichier flash que j'ai put récupéré sur votre site, j'ai crée un .swf qui pointe sur deux fichier .xml (il s'agit d'un map monde créer à l'origine pour facebook).

Seulement j'ai remarqué que le fichier lisait bien les données .xml sur mon ordinateur en local. Maintenant j'essaye d'instalé sur mon site online et cela ne marche plus. je n'ais pas le niveau assez dévellopé pour diagnostiquer la source du problème. j'ai téléchargé la dernière version de flash player pour firefox et je tombe sur le même problème, j'ai retiré les majuscules du nomage de fichier pensant que c'est coté serveur que le fichier n'était pas reconu.

Enfin j'ai vraiment besoin d'une solution, tous mes amis pouvant m'aiguillé sont parti en vacance, j'espère vraiment pouvoir compter sur votre aide.

merci

4 réponses

Orange73 Messages postés 1375 Date d'inscription dimanche 28 novembre 2004 Statut Membre Dernière intervention 2 août 2011
20 déc. 2008 à 20:06
Ce qu'il faut savvoir, c'est que ton chemin vers ton xml se fait a partir de ton fichier html et non a partir de ton swf. exemple :

J'ai a la racine de mon ftp index.html qui contient une anim flash situer dans le dossier "flash" (dossier a la racine aussi) + un xml dans ce meme dossier... dans mon flash il faut pas mettre "monXml.xml" mais "flash/monXml.xml", car le chemin se fait a partir de la page chargeant l'animation.

Donc je sait pas si c'est le cas pour toi ? sinon essaie oui de mettre "/legend.xml" si ce xml se trouve a la racine
Orange73 Messages postés 1375 Date d'inscription dimanche 28 novembre 2004 Statut Membre Dernière intervention 2 août 2011
20 déc. 2008 à 15:01
Hello,

Sa doit etre un probleme de chemin vers ton fichiers xml... dans ton flash le lien vers le xml est t'il bon ? car tu n'est plus en local.

Quel est l'arborescence de ton site ? et en local ? Quel est le chemin dans flash vers le xml ?
Noiro588 Messages postés 3 Date d'inscription mercredi 23 mai 2007 Statut Membre Dernière intervention 21 décembre 2008
20 déc. 2008 à 17:52
Je viens de regarder le code source, le fichier est inscrit directement à la racine ' var LegendXMLAdress = "legend.xml" '

et les fichiers ce trouve dans le même dossier sur le ftp, et je pointe de ma page html sur le fichier .swf ....

donc je vois pas, dois-je rajouter une syntaxe du genre = ./legend.xml ?????

merci pour votre aide Orange73
Noiro588 Messages postés 3 Date d'inscription mercredi 23 mai 2007 Statut Membre Dernière intervention 21 décembre 2008
21 déc. 2008 à 00:30
Oui, tu as parfaitement raison. Mon fichier ce trouve dans map/list.xml

je fait la modification. merci beaucoup :)
Rejoignez-nous