Problème d'un fichier .xml pas lu par mon .swf online [Résolu]

Noiro588 3 Messages postés mercredi 23 mai 2007Date d'inscription 21 décembre 2008 Dernière intervention - 20 déc. 2008 à 13:11 - Dernière réponse : Noiro588 3 Messages postés mercredi 23 mai 2007Date d'inscription 21 décembre 2008 Dernière intervention
- 21 déc. 2008 à 00:30
Bonjour le forum,

En fait j'ai un petit problème sur un fichier flash que j'ai put récupéré sur votre site, j'ai crée un .swf qui pointe sur deux fichier .xml (il s'agit d'un map monde créer à l'origine pour facebook).

Seulement j'ai remarqué que le fichier lisait bien les données .xml sur mon ordinateur en local. Maintenant j'essaye d'instalé sur mon site online et cela ne marche plus. je n'ais pas le niveau assez dévellopé pour diagnostiquer la source du problème. j'ai téléchargé la dernière version de flash player pour firefox et je tombe sur le même problème, j'ai retiré les majuscules du nomage de fichier pensant que c'est coté serveur que le fichier n'était pas reconu.

Enfin j'ai vraiment besoin d'une solution, tous mes amis pouvant m'aiguillé sont parti en vacance, j'espère vraiment pouvoir compter sur votre aide.

merci
Afficher la suite 

Votre réponse

4 réponses

Meilleure réponse
Orange73 1393 Messages postés dimanche 28 novembre 2004Date d'inscription 2 août 2011 Dernière intervention - 20 déc. 2008 à 20:06
3
Merci
Ce qu'il faut savvoir, c'est que ton chemin vers ton xml se fait a partir de ton fichier html et non a partir de ton swf. exemple :

J'ai a la racine de mon ftp index.html qui contient une anim flash situer dans le dossier "flash" (dossier a la racine aussi) + un xml dans ce meme dossier... dans mon flash il faut pas mettre "monXml.xml" mais "flash/monXml.xml", car le chemin se fait a partir de la page chargeant l'animation.

Donc je sait pas si c'est le cas pour toi ? sinon essaie oui de mettre "/legend.xml" si ce xml se trouve a la racine

Merci Orange73 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 97 internautes ce mois-ci

Commenter la réponse de Orange73
Orange73 1393 Messages postés dimanche 28 novembre 2004Date d'inscription 2 août 2011 Dernière intervention - 20 déc. 2008 à 15:01
0
Merci
Hello,

Sa doit etre un probleme de chemin vers ton fichiers xml... dans ton flash le lien vers le xml est t'il bon ? car tu n'est plus en local.

Quel est l'arborescence de ton site ? et en local ? Quel est le chemin dans flash vers le xml ?
Commenter la réponse de Orange73
Noiro588 3 Messages postés mercredi 23 mai 2007Date d'inscription 21 décembre 2008 Dernière intervention - 20 déc. 2008 à 17:52
0
Merci
Je viens de regarder le code source, le fichier est inscrit directement à la racine ' var LegendXMLAdress = "legend.xml" '

et les fichiers ce trouve dans le même dossier sur le ftp, et je pointe de ma page html sur le fichier .swf ....

donc je vois pas, dois-je rajouter une syntaxe du genre = ./legend.xml ?????

merci pour votre aide Orange73
Commenter la réponse de Noiro588
Noiro588 3 Messages postés mercredi 23 mai 2007Date d'inscription 21 décembre 2008 Dernière intervention - 21 déc. 2008 à 00:30
0
Merci
Oui, tu as parfaitement raison. Mon fichier ce trouve dans map/list.xml

je fait la modification. merci beaucoup :)
Commenter la réponse de Noiro588

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.