Datagrid et MasterPage [Résolu]

Signaler
Messages postés
5
Date d'inscription
mercredi 24 septembre 2008
Statut
Membre
Dernière intervention
5 décembre 2008
-
Messages postés
5
Date d'inscription
mercredi 24 septembre 2008
Statut
Membre
Dernière intervention
5 décembre 2008
-
Bonjour,

J'ai un leger problème,

J'ai une MasterPage pour mon site qui marche très bien a une exception pres,
j'ai besion d'y inserer une Datagrid et lorsque j'insere celle-ci je ne la voie pas à l'ecran, je l'ai forcé a visible="true"
et ses controls parents sont bien visible (elle inseré dans une div et je vois cette div dans le fichier source généré)
de plus lorsque je debugge je la voie dans l'attribut Master de ma page (avec d'ailleurs l'attribut visible a vrai!!)

du coup je me pose la question suivante : est-il possible d'inserer une DataGrid dans une MasterPage??

Si oui je suis preneur de toute idée quelque soit qui pourrais resoudre mon problème.

Merci d'avance!

2 réponses

Messages postés
417
Date d'inscription
vendredi 13 juin 2008
Statut
Membre
Dernière intervention
21 juillet 2010
1
Bonsoir,

Pour ta question : oui, il est bien entendu possible de mettre un DataGrid dans une MasterPage.
Cela dit, je n'ai pas bien compris si tu mettais ton DataGrid dans ta masterpage ou dans ta page de contenu : mais dans les deux cas, la réponse reste la même.
Une question bête : ton datagrid est-il bien lié à des données ?
La raison la plus simple pour laquelle un datagrid ne s'affiche pas est qu'il n'y a pas de données pour le remplir.
Si ce n'est pas cela, montre comment tu fais.

GGtry
Messages postés
5
Date d'inscription
mercredi 24 septembre 2008
Statut
Membre
Dernière intervention
5 décembre 2008

Bonjour,

merci d'avoir répondu,

En fait j'ai trouvé mon problème, il n'avait rien a voir avec la Datagrid,

en fait la datagrid est incluse dans ma MasterPage,
elle est initialisé dans le page_load de ma page courante, mais ma page courante herite d'une page de base et suite a une erreur de declaration du page_load de ma page courante je ne passais pas dans la methode qui initialise la Datagrid.

je ne sais pas si j'ai été clair,
mais en tout cas merci car c'est ta remarque qui m'as fais verifier toute l'initialisation de la datagrid.