Loader AS2 dans AS3 : le fichier charger ne fonctionne plus...

Résolu
Signaler
Messages postés
131
Date d'inscription
samedi 6 janvier 2007
Statut
Membre
Dernière intervention
4 janvier 2011
-
Messages postés
131
Date d'inscription
samedi 6 janvier 2007
Statut
Membre
Dernière intervention
4 janvier 2011
-
Bonjour !

Voila le problème. J'ai un swf en AS2 qui fait diapo avec des fotos qu'il charge depuis un serveur. Pour le test, je laisse les adresses codé en dur (et en absolu). L'AS2 fonctionne correctement.
Je créer un nouveau projet AS3, et je charge simplement l'AS2 comme ceci :

var url : URLRequest = new URLRequest("maDiapo.swf");
var loader = new Loader();
loader.load(url);
var clipDiapo = new MovieClip();
clipDiapo.addChild(loader);
this.addChild(clipDiapo);


Ce qui affiche en effet le "cadre" de ma diapo, mais qui n'affiche plus les images...
C'est très surement une mauvaise compréhension de mon propre code (j'apprends le flash que depuis quelques semaines et en autodidactes).

Donc si vous avez la moindre idée, merci beaucoup ^^

2 réponses

Messages postés
131
Date d'inscription
samedi 6 janvier 2007
Statut
Membre
Dernière intervention
4 janvier 2011
2
Je dirais même, je suis deux fois plus désolé !

J'avais un clip qui contenait un tout petit bout de code avec un _root dedans... et même après avoir traqué sans relâche tout les root, je l'avais oublié :S
Du coup, la solution était de changer _root par un this et le tour était joué.

Donc deux fois désolé pour le bordel que j'ai posté ici.
Et Merci quand même à ceux qui sont passé lire :)

Si un admin veut faire le ménage par ici, ya pas de problèmes ;)



[RESOLU]
Messages postés
131
Date d'inscription
samedi 6 janvier 2007
Statut
Membre
Dernière intervention
4 janvier 2011
2
PS : vraiment désolé pour le soucis que j'ai eu.
Je n'ai pas bien compris pourquoi l'éditeur n'as pas bien fonctionner :S