Préload avec un effet alpha progressif.

Résolu
Signaler
Messages postés
2
Date d'inscription
jeudi 9 octobre 2008
Statut
Membre
Dernière intervention
13 octobre 2008
-
Messages postés
2
Date d'inscription
jeudi 9 octobre 2008
Statut
Membre
Dernière intervention
13 octobre 2008
-
Bonjour.

Je suis novice en Flash et j'ai bricolé tant bien
que mal un site pour présenter un monologue que je vais jouer bientôt
(je suis comédien).
Je suis arrivé à bout de tous les problèmes
que j'ai pu rencontrer, tout seul comme un grand mais là, je bloque,
j'ai passé des heures sur Google et à éplucher les différents posts de
mediabox, je ne trouve pas.

Mon problème pourtant est à faire lever les yeux au ciel des programmeurs aguéris. Je l'expose:

Je
veux faire un préload avec une barre de téléchargement et un texte
dynamique qui affiche le pourcentage (ça c'est fait) et aussi le titre
de mon monologue qui s'affiche en fondu en même temps que le pré
chargement, au fil des octets préchargés. C'est là que je bloque, je ne
sais pas comment rédiger le code en utilisant la fonction _alpha.

Merci pour votre aide.

Bukingam

2 réponses

Messages postés
1203
Date d'inscription
lundi 10 mars 2003
Statut
Membre
Dernière intervention
23 juillet 2009
2
Salut,

[mode levage des yeux au ciel]
pour pouvoir faire apparaitre un texte dynamique en alpha, il faut absolument
* que la police de caractère soit intégrée (ou du moins les lettres que tu utilises dans ton titre).
* utiliser la propriété embedFonts (=true) du champs de texte

[mode professoral]
Hors, cela risque fort d'alourdir considérablement l'animation et surtout le preloader ... et donc cela va d'autant plus retarder son apparition.

A mon avis, dans ton cas le mieux a faire c'est de ne pas passer par un texte dynamique mais par un 'dessins' vectoriel de ton texte.
Pour cela, tu sélectionne ton champs de texte, du fait 'séparer' -> chaque lettres est devenu un champs de texte, tu fais a nouveau 'séparer' et tu obtient des éléments vectoriels

tu places  tous ces éléments dans un movieclip et ensuite, pas de problème pour jouer avec l'_alpha

@+
Messages postés
2
Date d'inscription
jeudi 9 octobre 2008
Statut
Membre
Dernière intervention
13 octobre 2008

Merci pour ton message.

J'ai solutionné le problème entre temps.

Cordialement.

RVMAn