Portabilité visual basic 2008

Signaler
Messages postés
7
Date d'inscription
mardi 8 avril 2008
Statut
Membre
Dernière intervention
22 mars 2009
-
Messages postés
3275
Date d'inscription
jeudi 3 avril 2008
Statut
Membre
Dernière intervention
14 septembre 2014
-
Bonjour à tous,

Je débute avec VB 2008 et j'essaye de développer de petites applications.
J'ai installé sur mon pc perso visual basic 2008 express et quand je compile et teste mes applications tout ce passe bien.

Le problème que je rencontre c'est lorsque j'arrive à ma boite où il y a une dizaines de pc avec toutes sorte de versions de Windows allant de 98 à xp avec les différentes version sp1...2 , et mon soucis est que mes applications ne trouvent pas les composants .NET dont elles ont besoin pour fonctionner.

J'ai essayé d'inclure les packaging de framework 3.5 mais il me demande la version 2 (dans certains cas) et il me semblait que la version 3.5 regrouper toutes les versions.

Je cherche donc une solution pour que lors de l'installation de mon application sur n'importe quel poste les composants manquant s'installent de façon transparante pour les utilisateurs.

N'étant pas informaticien de formation il se peut que je passe à côté de quelque chose de tout simple , mais j'avoue que après avoir essayé pas mal de chose ... je sèche.

Dernière question les résolutions d'écran varient aussi d'un poste à l'autre (oui c'est un peu le bazar dans ce park ...) et je voulais savoir si on pouvait adapter la taillle de l'application ainsi que ces composants (textbox, boutons, etc) à la résolution du pc sur lequel l'application s'execute.

Merci d'avance pour les réponses.

3 réponses

Messages postés
3275
Date d'inscription
jeudi 3 avril 2008
Statut
Membre
Dernière intervention
14 septembre 2014
4
si tu asaffaire à des vieilles bécanes compile pour le framework 2.0

pour les problèmes de résolutions il faut tout faire à la main

Bonjour chez vous !
Messages postés
7
Date d'inscription
mardi 8 avril 2008
Statut
Membre
Dernière intervention
22 mars 2009

Je trouve dommage de ne^pas utiliser le 3.5 vu que j'ai lu à droite et à gauche qu'il était possible de l'installer facilement (reste à savoir comment).

De plus le park informatique "est cencé" évolmuer et s'adapter aux évolution du monde informatique

Pour le problème de la résolution c'est bien ce que j'ai trouver comme réponse sur le net, je vais donc faire mes applications en basse/moyenne résolution et ça devrais allez.

Donc pour la 1ère question si quelqu'un à déjà eu et / ou régler le problème je suis preneur
Messages postés
3275
Date d'inscription
jeudi 3 avril 2008
Statut
Membre
Dernière intervention
14 septembre 2014
4
le framework 3.5 ne tourne pas sur win98 ça c'est sur

Bonjour chez vous !