Images absentes dans fichiers d'aide .chm

bruce207
Messages postés
106
Date d'inscription
mardi 4 mars 2008
Statut
Membre
Dernière intervention
2 mai 2012
- 20 août 2008 à 16:18
DblK
Messages postés
51
Date d'inscription
vendredi 30 janvier 2004
Statut
Membre
Dernière intervention
2 octobre 2008
- 20 août 2008 à 19:25
Bonjour,
mon problème est que lorsque je compile mon fichier d'aide .chm, les images ne sont pas présentes alors que dans les fichiers html ils sont présents.
Pourquoi cela et comment faire pour les afficher.
Merci

3 réponses

jmfmarques
Messages postés
7668
Date d'inscription
samedi 5 novembre 2005
Statut
Membre
Dernière intervention
22 août 2014
27
20 août 2008 à 16:27
Bonjour,

pas vraiment grand chose à voir avec VB6, mais tout à voir avec le mode d'emploi de t'outil utilisé pour créer ton fichier d'aide !
0
gillardg
Messages postés
3275
Date d'inscription
jeudi 3 avril 2008
Statut
Membre
Dernière intervention
14 septembre 2014
3
20 août 2008 à 16:45
ne faut il pas simplement inclure les images dans ton projet

Bonjour chez vous !
0
DblK
Messages postés
51
Date d'inscription
vendredi 30 janvier 2004
Statut
Membre
Dernière intervention
2 octobre 2008

20 août 2008 à 19:25
Bonjour,

Si tu utilises HTML Help Workshop ou alors FAR les images sont automatiquement chargées et compilées dans le CHM.
Néanmoins, toutes les images ne le sont pas forcement ; les images utilisées par exemple dans les javascripts ne le sont pas.
Pour les inclure, il faut créer une page "img.html" qui elle contiendra explicitement les images (via des balises img). Il te restera plus qu'à ajouter ce fichier à ton projet.

Il se peut (je n'ai pas vérifié) que les images dans les CSS ne soient pas également pris en compte.
La technique de remplacement citée plus haut, marchera forcement.

DblK
0