Erreur d'exécution "Invalid TLV Record" due à Crystal Report après installation

Signaler
Messages postés
30
Date d'inscription
mercredi 2 juillet 2008
Statut
Membre
Dernière intervention
11 août 2009
-
Messages postés
4
Date d'inscription
lundi 22 août 2005
Statut
Membre
Dernière intervention
16 mai 2012
-
Bonjour


j'ai installé une application vb6 qui utilise Crystal Report XI sur un pc qui n'a pas CR
l'installation s'effectue normalement
mais à l'exécution, j'ai une erreur :

"Erreur d'exécution -2147206249
       Invalid TLV Record"

Merci d'avance

Il y a deja deux personnes qui m'ont répondu (d'ailleurs désolée pour le double post mais je n'étais pas au bon theme)
Je vais citer leurs réponse ici comme ça tout le monde les verra

5 réponses

Messages postés
30
Date d'inscription
mercredi 2 juillet 2008
Statut
Membre
Dernière intervention
11 août 2009

bonjourcheval a écrit :
"
Et j'ai trouvé ceci :

http://it.toolbox.com/wiki/index.php/Solve_the_%22Invalid_TLV_Record%22_error_in_running_Crystal_Report

Walla
"

et aussi :
"Voir aussi :

https://boc.sdn.sap.com/node/243
"

Pour ma part, je suis en train de regarder  à la deuxieme adresse et d'essayer ce qui y est écrit (sans aller jusqu'à bidouiller les registres systeme pour le moment) avec les dll

Et PCPT a écrit :
"
TLV..., je dirais TreeListView
possible un problème de licence, CR est payant
"

en fait quand j'ai commencé mon appli, j'utilisais datareport et dataenvironment
et ensuite j'ai essayé CR
Mais j'ai telechargé la version d'evaluation de CR XI, peut-être que ça vient de là...
et puis comme j'ai réussi à faire à peu près ce que je voulais, j'ai continué...

enfin si qqn à d'autres idées
merci
@++
Messages postés
584
Date d'inscription
jeudi 28 décembre 2006
Statut
Membre
Dernière intervention
29 avril 2010
1
J'ai tellement souvent des erreurs avec CR que je me suis resigner a l'installer sur tout les poste qui utilise mon appli... mais si tu trouves une solution je suis preneur...

 
  zen69 aka Ortho Le Profett
 
Messages postés
228
Date d'inscription
mercredi 13 décembre 2000
Statut
Membre
Dernière intervention
8 août 2011

Les liens que je t'vait fourni proviennent de Google avec une recherche sur "Invalid TLV Record"

Probablement que tu pourra y trouver d'autres informations.
Messages postés
30
Date d'inscription
mercredi 2 juillet 2008
Statut
Membre
Dernière intervention
11 août 2009

bonjour
désolée du silence radio mais j'ai eu le droit a deux semaines de vacances

j'ai pu plus ou moins visualiser le rapport en utilisant une appli que j'ai trouvé sur internet
pour pouvoir visualiser les rapports, il faut toutes les dll indispensables à crystal. je suis tombée sur ça : 
http://mickypr.free.fr/Crystal%20Report%20XI%20-%20RunTime.exe

il faut l'installer sur les postes sur lesquels on deploie l'appli
l'exe vient de ce site :
http://www.developpez.net/forums/d15617-4/bases-donnees/business-intelligence/crystal/installer-exe-installer-cr/

sinon j'ai vu qu'il fallait en fait integrer au fichier d'installation 4 merge modules (msi)
qui sont dispo sur le site de business objects (support technique)
sinon ben je cherche toujours
d'autant que maintenant je rencontre un autre probleme...

@+
Messages postés
4
Date d'inscription
lundi 22 août 2005
Statut
Membre
Dernière intervention
16 mai 2012

copier les dll du dossier shared du cd d'installation de crystal report dans le répertoire d'installation de l'application et ça marchera bien