Problème requête SQL

[Résolu]
Signaler
Messages postés
11
Date d'inscription
lundi 16 juin 2008
Statut
Membre
Dernière intervention
28 juillet 2008
-
Messages postés
11
Date d'inscription
lundi 16 juin 2008
Statut
Membre
Dernière intervention
28 juillet 2008
-
Bonjour à tous,

J'ai un problème assez étrange sur une requête SQL ! (J'utilise vb6 et une base SQL server)
"Select * from Login Where User<gras>'" & username & "'"</gras>> Ne renvoie rien (alors qu'il devrait renvoyé un resultat)

sachant que :

"Select * from Login"
=> Renvoie tout les resultats (pas de problèmes)
"Select * from Login Where Prenom='" & prénom & "'"

=> Renvoie 1 résultat (pas de problèmes)

Vous vous dites probablement que le problème vient de la variable, mais non pas du tout, j'ai tester d'exécuter la requête directement sans passer par vb, et le problème est le même !
Un "Where" sur un champ d'une table ne renvoie rien (peu importe la valeur) alors que sur les autres champs de la même table il renvoie un resultat.

Donc voila je ne comprends du tout d'où provient le problème, si vous avez des solutions ou besoin de plus de précision n'hésitez pas

3 réponses

Messages postés
1402
Date d'inscription
mardi 1 mai 2007
Statut
Membre
Dernière intervention
7 octobre 2012
5
essaies avec
"Select * from Login Where [User]='" & username & "'"

<hr />... Y'en a même qui disent qu'ils l'ont vu voler.
Messages postés
1402
Date d'inscription
mardi 1 mai 2007
Statut
Membre
Dernière intervention
7 octobre 2012
5
Salut,
Peut être parceque User est un mot réservé..

<hr />... Y'en a même qui disent qu'ils l'ont vu voler.
Messages postés
11
Date d'inscription
lundi 16 juin 2008
Statut
Membre
Dernière intervention
28 juillet 2008

ça marche avec : [User]

Merci beaucoup pour la réponse rapide ;)