Upload files [Résolu]

Signaler
Messages postés
269
Date d'inscription
lundi 29 novembre 2004
Statut
Membre
Dernière intervention
23 août 2011
-
Messages postés
269
Date d'inscription
lundi 29 novembre 2004
Statut
Membre
Dernière intervention
23 août 2011
-
Salut !

dans mon code , la ligne $_FILE['myFile'][type] ne marche que quand le fichier est petit et quand cela depasse les 1MB cella ne marche pas !!!!!

 est ce  que quelqu'un connaitrait il ce probleme ?
J.BAHOLE

12 réponses

Messages postés
269
Date d'inscription
lundi 29 novembre 2004
Statut
Membre
Dernière intervention
23 août 2011

le probleme etait ailleur !!! merci quand meme les gars!

J.BAHOLE
Messages postés
1980
Date d'inscription
dimanche 20 février 2005
Statut
Membre
Dernière intervention
24 septembre 2012
5
Bonsoir,

voir le php.ini : memory_limit et upload_max_filesize

à+
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
40
salut

le type n'est pas a prendre en compte. c'est un truc envoye par le navigateur, c'est donc qqch de dangereux...
Messages postés
1980
Date d'inscription
dimanche 20 février 2005
Statut
Membre
Dernière intervention
24 septembre 2012
5
J'ai lu trop vite la question... bizarre ton problème. Essaie avec d'autres navigateurs ? Sinon oui, comme le dit coucou, de toute façon il ne faut pas utiliser cette variable.
Messages postés
269
Date d'inscription
lundi 29 novembre 2004
Statut
Membre
Dernière intervention
23 août 2011

J'AI ESSAIYE ... TOUJOURS LA MEME CHOSE!!!
J.BAHOLE
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
40
salut

le type n'est pas a prendre en compte. c'est un truc envoye par le navigateur, c'est donc qqch de dangereux...

(MOI AUSSI TOUJOURS LA MEME CHOSE !!!)
Messages postés
269
Date d'inscription
lundi 29 novembre 2004
Statut
Membre
Dernière intervention
23 août 2011

pourkoi ce code me return FALSE meme quand le fichier et petit et surtout que au paravant cela marchait si bien
move_uploaded_file($_FILES[myfile]['tmp_name'],$tempfile);
J.BAHOLE
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
40
$_FILES[myfile]

c'est pas valide ca... ca devrait te lever un warning aussi...
Messages postés
269
Date d'inscription
lundi 29 novembre 2004
Statut
Membre
Dernière intervention
23 août 2011

et ce qui est bizar : la variable $_FILES["myfile"]["error"] est egale a ZERO

J.BAHOLE
Messages postés
269
Date d'inscription
lundi 29 novembre 2004
Statut
Membre
Dernière intervention
23 août 2011

pourquoi c'est pas valide?
je comprend pas ! :

J.BAHOLE
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
40
on met des guillemets autour des chaines de caracteres...
Messages postés
269
Date d'inscription
lundi 29 novembre 2004
Statut
Membre
Dernière intervention
23 août 2011

my bad! erreure de clavier!!! Mais $_FILES["MyFile"][error"] est egale a ZERO je comprend pas pourkoi!

J.BAHOLE