Impossible d'envoyer un mail avec System.Net.Mail; [Résolu]

Messages postés
5
Date d'inscription
jeudi 10 juillet 2008
Dernière intervention
11 juillet 2008
- 10 juil. 2008 à 13:13 - Dernière réponse :
Messages postés
60
Date d'inscription
dimanche 9 janvier 2005
Dernière intervention
21 août 2008
- 10 juil. 2008 à 14:12
Bonjour à tous,

Tout d'abord merci pour votre site très complet, c'est vraiment pratique !!!

Mon problème est le suivant : je dois réaliser un projet qui envoie un mail en C#.
J'ai codé ça :


public class MailTry

{

private void SendMailMesssage()

{

MailMessage mail = new MailMessage();

mail.From = new MailAddress("nom<nom@caramail.com>");

mail.To.Add(new MailAddress("nom@caramail.com"));

mail.SubjectEncoding = Encoding.GetEncoding("iso-8859-1");

mail.Subject = @"Test text";

mail.BodyEncoding = Encoding.GetEncoding("iso-8859-1");

mail.Body = @"Test d'envoi de mail en C# .NET 2.0";

SmtpClient smtp = new SmtpClient();

smtp.Host = "Smtp.caramail.lycos.fr";

smtp.Port = 25; // default.

smtp.Credentials = new System.Net.NetworkCredential("nom@caramail.com", "password");

try

{

smtp.Send(mail);

}

catch (Exception ex)

{

DialogResult exitConfirm = (MessageBox.Show("erreur"));

}

}

}
Et dans le main, j'appelle simplement ma méthode

MailTry m = new MailTry();

Je n'ai pas d'erreur, on voit la console qui se lance et qui reste 1 seconde à l'écran et ça semble avoir marcher. Mais rien n'est envoyé. J'ai désactiver les pare-feux, les antivirus etc etc et rien n'y fait.

Quelqu'un pourrait-il m'aider ?
D'avance je vous remercie...
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Messages postés
60
Date d'inscription
dimanche 9 janvier 2005
Dernière intervention
21 août 2008
- 10 juil. 2008 à 13:20
3
Merci
Salut,

Met un "Console.Read()" à la fin de ton main pour que la console ne se ferme pas automatiquement, tu pourras alors voir si il y a quelconque message dessus.

Si tu possèdes une adsl-box, vérifie dans sa config ou auprès de ton provider que le port 25 n'est pas bloqué par défaut.

a++

Merci krishou 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 91 internautes ce mois-ci

Commenter la réponse de krishou
Messages postés
5
Date d'inscription
jeudi 10 juillet 2008
Dernière intervention
11 juillet 2008
- 10 juil. 2008 à 13:50
0
Merci
Bien vu pour le port !! Je dois effectivement (avec Bluewin si ça en intéresse d'autres !) changer le port 25 au port 465... J'attends maintenant de voir si je reçois qqch ou pas... Merci déjà !
Commenter la réponse de cs_calisca
Messages postés
60
Date d'inscription
dimanche 9 janvier 2005
Dernière intervention
21 août 2008
- 10 juil. 2008 à 14:12
0
Merci
Avec plaisir...

C'était un coup de chance, je venais de lire un article sur le blocage du port 25 chez la plupart des providers pour eviter le spamming par des pc ghosts. ;)
Commenter la réponse de krishou

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.