Passage Delphi 4 -> Delphi 6 [Problème abvec l'opérateur NULL]

cs_yoannd Messages postés 305 Date d'inscription lundi 7 janvier 2002 Statut Membre Dernière intervention 10 août 2011 - 3 janv. 2003 à 09:50
cs_yoannd Messages postés 305 Date d'inscription lundi 7 janvier 2002 Statut Membre Dernière intervention 10 août 2011 - 22 mai 2003 à 13:52
Bonjour !

Je suis en train de passer une appli faite en delphi 4 vers du Delphi 6 et à un endroit, il y a un appel vers une api Windows (ExtractIcon). Il y a aussi un test pour savoir si celle-ci renvoie NULL. NULL passe en D4, mais pas en D6... Faut-il rajouter un truc dans les uses (il dit que NULL n'est pas déclaré), ou alors faut faire autre chose...

Merci d'avance à qui me donnera la solution !

Yoann

2 réponses

loicbernard Messages postés 16 Date d'inscription jeudi 22 mai 2003 Statut Membre Dernière intervention 15 juin 2005
22 mai 2003 à 12:47
j'ai également ce problème pour passer un programme de delphi 5 à delphi 6.
je ne sais pas si vous avez trouvez la solution depuis le mois de janvier mais si c'était le cas ce serait vraiment gentil de m'en faire part.
merci d'avance

loic
0
cs_yoannd Messages postés 305 Date d'inscription lundi 7 janvier 2002 Statut Membre Dernière intervention 10 août 2011 7
22 mai 2003 à 13:52
Je ne travaille plus sur le passage de Delphi 4 à Delphi 6 pour l'instant car j'ai eu d'autres projets entre temps, mais la question reste tout de même sur le tapis. Je n'ai toujours pas la solution à ce problème de NULL...
0