IIS 6.0 probleme avec ASP.NET 1.0 et 2.0

Signaler
Messages postés
32
Date d'inscription
mercredi 25 juillet 2001
Statut
Membre
Dernière intervention
20 janvier 2009
-
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
-
Bonjour tous le monde,

J'ai créé un repertoire virtuel sur le site par default dans IIS 6.0
Le problème c'est que le site par default est gérer en ASP 1.0 et le repertoire virtuel converti en application est en ASP 2.0 ce qui provoque aléatoirement un message d'erreur de type "Application non disponible" je suis obligé d'appliquer le ASP 1.0 puis remettre le ASP 2.0 c'est pour le moment le seul moyen que j'ai trouvé.

Avez vous une solution pour régler ce problème.

Merci d'avance. Alexandre.

ALEX001

1 réponse

Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
27
Bonjour,

il n'est pas possible possible de mixer ASP.net 1 et ASP.net 2 dans un meme site, chaque site est inclu dans un Pool d'application. Au niveau process un pool d'application correspond au process w3wp.exe ce process contient autant d'appdomain que de site web. Comme on ne peut pas charger la CLR1.0 et 2.0 au sein du meme AppDomain ni meme au sein du meme process, la seule solution consiste à faire un nouveau site web que tu isoles dans un appdomain séparé.

<hr />Cyril - MSP - MCPD ASP.net & MCTS SQL - Consultant indépendant