Inet Activé dans composant mais erreur

Résolu
franck1709
Messages postés
2
Date d'inscription
vendredi 27 juin 2008
Statut
Membre
Dernière intervention
30 juin 2008
- 30 juin 2008 à 13:03
franck1709
Messages postés
2
Date d'inscription
vendredi 27 juin 2008
Statut
Membre
Dernière intervention
30 juin 2008
- 30 juin 2008 à 14:39
Bonjour,

J'ai trouvé de nombreuse source sur ce sujet , j'ai meme fait fonctionner avec succès deux clients très complet utilisant inet .
Pourtant le code de base ne marche pas chez moi :

Dim Inet1 As Inet
With Inet1
.Protocol= icFTP ' Ca bloque dès cette ligne : "runtime error 91 Object variable or with block variable not set "
.URL= "ftp://utilisateur:mdp@adresse"
.Execute "PUT Text1.txt Text1.txt"
End With

Pourtant j"'ai bien activé le composant microsoft internet control 6.0
Je ne comprend pas pourquoi ca marche pour tout le monde sauf moi..

Ce qui est bizarre, c'est que les sources plus complètescomme celles ci: http://www.vbfrance.com/codes/FTP-GET-PUT-V1_5953.aspx
et
http://www.vbfrance.com/codes/CLIENT-FTP-PERSO-AVEC-INET_6249.aspx
fonctionnent correctement avec inet sans que j'arrive à voir ce qu'il ya de plus pour que cela fonctionne..

2 réponses

PCPT
Messages postés
13280
Date d'inscription
lundi 13 décembre 2004
Statut
Membre
Dernière intervention
3 février 2018
49
30 juin 2008 à 13:11
salut,
tu as dû oublier de poser un 'Inet1' sur ta form. et dans quel cas tu n'as pas besoin de la première ligne de déclaration

++
<hr size="2" width="100%" />Prenez un instant pour répondre à [infomsg_SONDAGE-POP3-POUR-CS_769706.aspx ce sondage] svp  
3
franck1709
Messages postés
2
Date d'inscription
vendredi 27 juin 2008
Statut
Membre
Dernière intervention
30 juin 2008

30 juin 2008 à 14:39
Merci Beaucoup !

C'est un détail que je n'avai vu marquer nul part , j'espère que cela poura profiter à d'autres débutants comme moi.
0