Propriété non valide / erreur 380... [Résolu]

Signaler
Messages postés
56
Date d'inscription
samedi 24 mai 2008
Statut
Membre
Dernière intervention
6 novembre 2010
-
Messages postés
56
Date d'inscription
samedi 24 mai 2008
Statut
Membre
Dernière intervention
6 novembre 2010
-
Bonjour,

Dans mon Userform, j'ai rajouté deux combobox afin de rajouter des options supplméentaires.

Il ne s'ouvre plus lors de l'ouverture du fichier. Et sil s'ouvre, mes combobox (dont la rowsource se trouve définie dans UserForm_Initialize ne fonctionnent plus.

J'ai nommé mon Userform : formulairedessaisieCPHT, mais dans le code, il se trouve nommé Userform. J'ai fait le test en remplaçant les deux termes, mais ça ne fonctionne pas.

Mes pb ont commencé quand j'ai voulu rajouter les zones visuelles
Ci-joint un extrait du code :
Private Sub UserForm_Initialize()<?xml:namespace prefix o ns "urn:schemas-microsoft-com:office:office" /??>

fichier2 = [x1] & "" & [a1] & ".avi"

WindowsMediaPlayer1.URL = fichier2

WindowsMediaPlayer1.Controls.play

WindowsMediaPlayer1.Controls.Stop

WindowsMediaPlayer1.Controls.Pause

WindowsMediaPlayer1.Controls.fastForward

WindowsMediaPlayer1.Controls.fastReverse

' Initialisation de la liste de la ComboBox1

ComboBox1.RowSource = "z1:z" & ActiveSheet.UsedRange.Rows.Count

' Sélection de l'index 1 de la liste et de même pour la suite des combobox...

ComboBox1.ListIndex = 0

ComboBox2.RowSource = "aa1:aa" & ActiveSheet.UsedRange.Rows.Count

ComboBox2.ListIndex = 0

Evalmodif.RowSource = "z1:z" & ActiveSheet.UsedRange.Rows.Count

Evalmodif.ListIndex = 0

NomSaisieBis.RowSource = "p1:p" & ActiveSheet.UsedRange.Rows.Count

NomSaisieBis.ListIndex = 0

ZoneVisuelle.RowSource = "g1:g" & ActiveSheet.UsedRange.Rows.Count

ZoneVisuelle.ListIndex = 0

zoneVisuellebis.RowSource = "g1:g" & ActiveSheet.UsedRange.Rows.Count

zoneVisuellebis.ListIndex = 0

ZoneDép2.RowSource = "n1:n" & ActiveSheet.UsedRange.Rows.Count

ZoneDép2.ListIndex = 0

ZonePré2.RowSource = "m1:m" & ActiveSheet.UsedRange.Rows.Count

ZonePré2.ListIndex = 0

Action.RowSource = "h1:h" & ActiveSheet.UsedRange.Rows.Count

Action.ListIndex = 0

'Et plein d'autres encore

Cordialement

De plus, comme tout est planté, j'ai tenter de tout refaire siur ma sauvegarde et avant de pouvoir la sauvegarder, j'ai tout planté. De ce fait, je n'ai plus d'outil.

Hidozo

3 réponses

Messages postés
56
Date d'inscription
samedi 24 mai 2008
Statut
Membre
Dernière intervention
6 novembre 2010

bonjour,


 


Pb résolu,


Une des lignes du codes faisait référence à une liste qui se trouvait dans une autre page. De ce fait, cela posait un problème.


Merci pour tout


 


Hidozo
Messages postés
56
Date d'inscription
samedi 24 mai 2008
Statut
Membre
Dernière intervention
6 novembre 2010

essai document joint
Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
18
Comme tu ne spécifies pas de feuilles lorsque tu appelles des plages, es-tu certain que le userform s'ouvre avec la bonne feuille affichée ?

Dans cette ligne
ICI