Problème de valeur par défaut de Checkbox [Résolu]

Signaler
Messages postés
80
Date d'inscription
lundi 22 octobre 2007
Statut
Membre
Dernière intervention
30 juillet 2008
-
Messages postés
80
Date d'inscription
lundi 22 octobre 2007
Statut
Membre
Dernière intervention
30 juillet 2008
-
Voilà, je suis en train de faire un formulaire sous Access, et je me trouve confronté à un problème
J'utilise un certain nombre de Checkbox, mais celles ci ne se réinitialisent pas.

En gros , je voudrais que lorsque je lance le formulaire , chaque Checkbox ne soit pas coché.
Dans les options de chacune , j'ai règlé : défault value = faux
Je pensais que c'était comme ca , mais visiblement non.

Si quelqu'un pouvait m'aider , je lui en serais grandement reconnaissant.

Merci,

AiDuK

3 réponses

Messages postés
1402
Date d'inscription
mardi 1 mai 2007
Statut
Membre
Dernière intervention
7 octobre 2012
5
Salut,

je crois que pour les checkbox les valeurs sont:
0 pur Checked
1 pour Unchecked
2 pour Grayed

essaies avec
défault value = 1

ou bien fais dans Form_Laod

Check1.Value=UnChecked

<hr />... Y'en a même qui disent qu'ils l'ont vu voler.
Messages postés
14008
Date d'inscription
samedi 29 décembre 2001
Statut
Modérateur
Dernière intervention
28 août 2015
76
Salut
Le VB de Access est du VBA, pas du .NET
Catégorie modifiée

Apparemment, sous VBA, la "Value" d'une CheckBox est Vrai (-1) ou Faux (0) et n'utiliserait pas le traditionnel vbChecked (1) et vbUnChecked (0).
Pour DefaultValue, voir l'aide

Vala
Jack, MVP VB
NB : Je ne répondrai pas aux messages privés

<hr />Le savoir est la seule matière qui s'accroit quand on la partage (Socrate)
Messages postés
80
Date d'inscription
lundi 22 octobre 2007
Statut
Membre
Dernière intervention
30 juillet 2008

Merci à vous deux pour l'aide, je commence à bien avancer dans mon formulaire ;)