Objets disparaisent pendant la copie de répertoires [Résolu]

Signaler
Messages postés
8
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
22 février 2011
-
Messages postés
8
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
22 février 2011
-
Bonjour,
Pour une copie de dossiers, Copy ou CopyFolder sont utilisés.
Pendant l'exécution de cette copie, les objets menu et labels disparaissent pour laissé un fond blanc! Ils réapparaisent une fois la copie terminée!
Pas esthétique, y a-t-il une solution ?
Merci.

Note: l' instruction "CopyFolder" génère une erreur avec  CopyFolder Dossier1 Dossier2: vide Dossier1 mais ne peut le supprimer (accès refusé)
La solution a été:
' Supprime les fichiers de Dossier2
dele = Dossier2 + "\*.*"
fso.DeleteFile (dele)
'Supprime les sous répertoires de Dossier2 et le laisse vide
 fso.DeleteFolder (dele)

Querieux <qtl><qtlbar>http://qtl.co.il/affhttp://qtl.co.il</qtlbar></qtl>

3 réponses

Messages postés
8
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
22 février 2011

La Note parlait de deletefolder et non de Copy! Mes excuses.

Querieux<qtl><qtlbar>http://qtl.co.il/affhttp://qtl.co.il</qtlbar></qtl>
Messages postés
682
Date d'inscription
vendredi 6 avril 2007
Statut
Membre
Dernière intervention
4 août 2012
6
pour le fond blanc mets un Do Events juste avant la procédure de copie ça donnera à ta machine de raffraichir l'affichage

pour le reste hélas je n'ai pas de solution

ne mets Réponse acceptée que SI tu as la solution à ton probleme sinon tu risque d'attendre longtemps une réponse utile

[reglement.aspx ]si c'est la solution, penser : REPONSE ACCEPTEE
Messages postés
8
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
22 février 2011

Résolu en partie. Mais si on clic sur la fenêtre pendant la copie, le menu seul disparait.

Querieux<qtl><qtlbar>http://qtl.co.il/affhttp://qtl.co.il</qtlbar></qtl>