Javascript et Php/MySql [Résolu]

Signaler
Messages postés
166
Date d'inscription
mercredi 27 juin 2007
Statut
Membre
Dernière intervention
31 mars 2014
-
Messages postés
166
Date d'inscription
mercredi 27 juin 2007
Statut
Membre
Dernière intervention
31 mars 2014
-
Bonjour à tous,
actuellement sur un projet, je viens de rencontrer un petit soucis d'où cette présente question.

Voilà mon problème:
J'ai réalisé entièrement un site avec javascript, tout est fonctionnel.
Une nouvelle étape de mon projet a consisté à créer un accès pour membres inscrits. Jusque là, tout va bien.
J'ai en effet pu réaliser cela. Cependant après la validation du login et la redirection vers mon site entièrement realisé en html/javascript (dsl de me répéter...), ce dernier ne fonctionne plus comme il le devrait.
Alors qu'en l'ouvrant simplement avec mon navigateur, tout fonctione comme cela a été pensé, lorsqu'il a été appelé après la validation du login = > ça se gate.

Un exemple de ce qui ne marche pas:

Un clic sur un bouton de ma page provoque:


Le simple remplissage d'une div par la fonction javascript:
   => document.getElementById('mon_id').innerHTML=qqchose; ne fonctionne pas bien.
Si ce qqchose n'est qu'une chaîne de caractère, il n'y a pas de soucis:
    => document.getElementById('mon_id').innerHTML="salut";  aucun problème.
Mais si ce quelque chose contient des balises, ça ne va plus:
 =>document.getElementById('new1').innerHTML=tmp;
   avec tmp=""; ne fonctionne pas !!

Or je ne comprends pas du tout le pourquoi du comment, étant donné que cela fonctionne qd le fichier html est directement ouvert par le navigateur (IE7 pour info).

Quelqu'un aurait-il une idée quand au pourquoi du comment ?

Voici quelques précisions, je travaille en local avec EasyPhp, windowsXP et IE7.
la redirection vers mon fichier html est faite par cela:
=>  header("mon fichier.html");  ce dernier étant placé dans le répertoire www de EasyPhp


Merci d'avance et à bientôt.

Signé Sagat

2 réponses

Messages postés
166
Date d'inscription
mercredi 27 juin 2007
Statut
Membre
Dernière intervention
31 mars 2014
1
Merci coucou747,
mais cela était une erreur de frappe de ma part ^^.
Désolé, je devrais toujours me relire avant de poster un message.

Sinon, j'ai bêtement résolu mon pb, et j'avoue avoir honte:
=> le chemin d'accès vers l'image n'était plus bon.

En mettant l'image dans le répertoire www, le soucis n'existe plus.

Je suppose que cela est dû à une sécurité empechant un serveur d'aller chercher qqchose sur le disque dur d'un utilisateur.


Bref, tout semble rouler maintenant.


Mais encore merci d'avoir jeter un coup d'oeil à mon pb.

Signé Sagat
Messages postés
12303
Date d'inscription
mardi 10 février 2004
Statut
Modérateur
Dernière intervention
30 juillet 2012
39
  header("mon fichier.html");
ca ne fait pas une redirection...
  header("Location: http://..../monfichier.html");

evite les espaces dans les noms d'ailleur.