Probleme insertion requete imbrique [Résolu]

Signaler
Messages postés
131
Date d'inscription
dimanche 2 décembre 2007
Statut
Membre
Dernière intervention
23 juillet 2009
-
Messages postés
131
Date d'inscription
dimanche 2 décembre 2007
Statut
Membre
Dernière intervention
23 juillet 2009
-
CREATE table SM_properties (id INT(4) NOT NULL AUTO_INCREMENT, postcode VARCHAR(9), price INT(6), branch VARCHAR(150), bedrooms int(2), address1 VARCHAR(150), address2 VARCHAR(150), address3 VARCHAR(150), agentDescription TEXT, propWeek varchar(10), agentID INT(4), PRIMARY KEY(id));




 CREATE TABLE SM_image(
id INT( 4 ) NOT NULL AUTO_INCREMENT ,
id_properties INT( 4 ) NOT NULL ,
img_name VARCHAR( 255 ) ,
PRIMARY KEY ( id ) ,
FOREIGN KEY ( id_properties ) REFERENCES SM_properties( id )
)




et je voudrais faire une insertion d'une propriete mais je suis bloquer je sais pas comment faire pour que l image soit aussi inserer avec le meme id_propiete de la propriete.

$Query = "INSERT INTO SM_properties VALUES ('0', '".mysql_escape_string($formValue['postcode'])."','".mysql_escape_string($f­ormValue["price"])."', '".mysql_escape_string($formValue["branch"])."', '".mysql_escape_string($formValue["bedrooms"])."',
'".mysql_escape_string($address1)."', '".mysql_escape_string($formValue["address2"])."','".mysql_escape­_string($formValue["address3"])."', '".mysql_escape_string($formValue["agentDescription"])."','".mysq­l_escape_string($propWeek)."',
'".mysql_escape_string($agentID)."')";

je dois faire une seconde requete pour inserer la photo avec l'id de la propriete de la precedemment ajoute
je fais ca :

$Query2="INSERT INTO SM_image VALUES '0',je sais pas ce que je dois mettre ici pour avoir l id de la propriete,'".mysql_escape_string($imgpath)."','".mysql_escape_string($imgpa­th2)
."')";

3 réponses

Messages postés
1423
Date d'inscription
mardi 14 décembre 2004
Statut
Membre
Dernière intervention
29 décembre 2012
4
http://ch2.php.net/manual/fr/function.mysql-insert-id.php
t'auras le dernier id, après jcomprend pas cke tu veux en faire de ton truc >_<

Il vaut mieux poser une question et passer pour bête que le rester toute sa vie

 Les geeks n'ont pas une case en moins ils commencent juste à compter à partir de zéro
Messages postés
131
Date d'inscription
dimanche 2 décembre 2007
Statut
Membre
Dernière intervention
23 juillet 2009

oui j ai deja essayé ca mais il me retourne 0
Je veux juste quand j insere une propriété il m'insere aussi mon image de la propriété...
Avant javais tout dans la meme table c'était simple mais la j'avoue que je suis completement perdu j'ai jamais fait ca .
pour les $formvalue fait pas attention ca fonctionne c 'est un tableau de valeur posté . Avant ca marché quand je mettais les image dans la table propriété.
Messages postés
131
Date d'inscription
dimanche 2 décembre 2007
Statut
Membre
Dernière intervention
23 juillet 2009

J ai regle mon probleme ca marche en  fait la fonction c'est moi qui marche pas lol.