Problème avec lineTo

Résolu
cs_benedict Messages postés 187 Date d'inscription mercredi 25 septembre 2002 Statut Membre Dernière intervention 7 mai 2009 - 30 avril 2008 à 13:24
dj_ouf Messages postés 221 Date d'inscription vendredi 15 avril 2005 Statut Membre Dernière intervention 6 septembre 2011 - 30 avril 2008 à 14:45
Ce code dessine une ligne rouge parfaitement dans une animation test
"this.createEmptyMovieClip("mShape",this.getNextHighestDepth());
            mShape.lineStyle(0,0xFF0000);
            mShape.moveTo(0,0);
            mShape.lineTo(100,100);"

Mais dans mon application, il ne dessine plus rien du tout.
Comment ça se fait, bon sang de bonsoir ?

Merci de votre aide

Benedict

3 réponses

dj_ouf Messages postés 221 Date d'inscription vendredi 15 avril 2005 Statut Membre Dernière intervention 6 septembre 2011
30 avril 2008 à 13:56
salut,

Quelle est la différence entre "une animation de test" et "une application" ?

ton soucis doit être un problème de context, p-e à cause du ciblage de this ?

dis nous en plus sur le contexte de ton morceau de code stp
3
cs_benedict Messages postés 187 Date d'inscription mercredi 25 septembre 2002 Statut Membre Dernière intervention 7 mai 2009 2
30 avril 2008 à 14:25
Merci.
Le problème est résolu : j'ai mis le code dans une fonction séparée et ça marche au petit poil.
Benedict
0
dj_ouf Messages postés 221 Date d'inscription vendredi 15 avril 2005 Statut Membre Dernière intervention 6 septembre 2011
30 avril 2008 à 14:45
Bien joué!

Très souvent le soucis est simple, une histoire de contexte ;)

Ton this devait certainement cibler autre chose!

Alelouia
0
Rejoignez-nous