Problème avec domready (je pense)

jpegb4 Messages postés 2 Date d'inscription mardi 8 avril 2008 Statut Membre Dernière intervention 7 septembre 2008 - 17 avril 2008 à 23:43
jpegb4 Messages postés 2 Date d'inscription mardi 8 avril 2008 Statut Membre Dernière intervention 7 septembre 2008 - 7 sept. 2008 à 20:02
Bonjour à tous !
voilà je débute doucement en Ajax j'utilise mootools pour m'en sortir un peu mieux.
J'ai intégré aussi le script multibox de phatfusion.
Mon problème :
    Aprés le chargement d'une partie de page qui contient des nouveaux éléments, je ne peux pas utiliser le script multibox sur un élément qui vient de s'afficher. je pense à cause de la déclaration des scripts qui utilise le fameux"domready" , j'ai l'impression que celui-ci ne se met pas à jour.
Voici mes scripts si cela peut aider :
multibox :
var box = {};
            window.addEvent('domready', function(){
                box = new MultiBox('mb', {descClassName: 'multiBoxDesc', onClose:function(){location.reload();}});
            });
chargement partie de page :
window.addEvent('domready', function(){
                var url = "pages/admin/"+prest+".php";
                    new Ajax(url, {
                        method: 'get',
                        update: $('modifier2')
                    }).request();
                });

merci beaucoup !
PS : j'habite en RDZ alors si vous avez une adresse pour acheter des cordes pas chères...

2 réponses

jfipre Messages postés 1 Date d'inscription jeudi 24 juillet 2003 Statut Membre Dernière intervention 6 septembre 2008
6 sept. 2008 à 17:54
Salut,
As tu trouvé la solution ? j'ai le même problème avec une mise à jour AJAX d'une zone comprenant des appels multibox.

Merci à toi ou à celui qui aurait une piste pour ce problème
0
jpegb4 Messages postés 2 Date d'inscription mardi 8 avril 2008 Statut Membre Dernière intervention 7 septembre 2008
7 sept. 2008 à 20:02
Salut !
Non pas de solutions pour le moment. moi j'ai eu la possibilité de faire un meta refresh dans le cadre de mon code pour éviter ce soucis.
Je peux aussi te dire que sur le forum de phatfusion aucune solution n'a été donné.
Bonne soirée
0