Flash MFC Visual Studio.NET

Résolu
Signaler
Messages postés
18
Date d'inscription
jeudi 13 décembre 2007
Statut
Membre
Dernière intervention
23 mai 2008
-
Messages postés
18
Date d'inscription
jeudi 13 décembre 2007
Statut
Membre
Dernière intervention
23 mai 2008
-
Salut tout le monde,
j'ai un petit probleme quand a l'insertion d'une animation flash dans une boite de dial toute bebete :
j'utilise le controle ActiveX flash9e.ocx pour cela
je creer une variable membre de ce controle (on va dire m_player)
et je demande la lecture grace a put_Movie :




// TODO: Add extra initialization here
m_player.put_Movie("C:\intro.swf");




Le truc c que l'animation ne se lance pas, alors que j'ai essayé sous Visual Studio 6.0 avec exactement la meme manip et ça marche ! (sauf que sous VS.6 la methode s'appele SetMovie, en effet les fichiers de la classe objet CShockwaveflash (.h et .cpp) sous VS.6 et VS.NET decrivent des methodes identiques avec des appelations differentes mé bon ça c'est qu'un detail).
Le pire : quand jouvre le projet realisé sous VS.6 avec VS.Net l'animatin marche bien aussi.
Pkoi je ne peu pas le faire directement dans visual studio.NET ?? (bien que le code soit correct)


Merci tout le monde, toute aide est la bienvenue

1 réponse

Messages postés
18
Date d'inscription
jeudi 13 décembre 2007
Statut
Membre
Dernière intervention
23 mai 2008

Bon j'ai supprimé le fichier .ncb, qui se trouve dans le répertoire de la solution avant de lancer Visual Studio pour qu'il le recrée. A priori ca a résolu le problème.
Va savoir pkoi ?!