Problemes performance avec serveur lamp

Signaler
Messages postés
67
Date d'inscription
mercredi 14 février 2007
Statut
Membre
Dernière intervention
22 mars 2009
-
Messages postés
962
Date d'inscription
samedi 19 janvier 2002
Statut
Membre
Dernière intervention
2 août 2010
-
Bonsoir à tous !


J'ai un serveur lamp sur ubuntu et j'ai des gros problèmes de perf sur ma base mysql.


Quand je vais sur phpmyadmin et que je fais etat du serveur, voila les parametres qui posent problemes :


Created_tmp_disk_tables  3k
Opened_tables               313


Les valeurs sont tellement montées tout a l'heure a cause de l'activité que j'ai eu une erreur 111 avec un probleme de socket.


Qu'est ce que je peux faire ?




Merci d'avance pour votre aide.


 

2 réponses

Messages postés
2480
Date d'inscription
jeudi 30 novembre 2006
Statut
Membre
Dernière intervention
14 janvier 2011
18
Salut,

Je suis loin d'être expert en bases de données, j'ai pas vocation à être dba, mais j'vais quand même essayer de dire des choses... Qui ne te feront peut-être pas avancer dans l'immédiat, mais...

1/ Sans avoir ton code source, il est difficile de dire si c'est normal ou pas.
2/ Sans connaitre les conditions d'utilisation, on ne peut pas non plus savoir si c'est normal ou pas : est-ce un serveur de dév, ou est-ce que tu héberges un/des site(s) dessus ?

Bon, je t'apporterai pas la réponse, mais avec plus d'informations, d'autres seront peut-être en mesure de t'en dire plus.

<hr size="2" width="100%" />Neige

N'hésitez pas à lire la doc de PHP avant de poser des questions triviales...
Messages postés
962
Date d'inscription
samedi 19 janvier 2002
Statut
Membre
Dernière intervention
2 août 2010
1
Salut,

Tout d'abord je vais préciser, moi aussi, que je suis loin d'être un expert en serveur de base de données. Ceci dit je connais relativement bien la configuration de mysql et ce qu'il faut surveiller. Mais, je le répete, je ne suis pas un expert, d'ailleurs je n'en ai jamais vu sur ce site, des experts dans ce domaine...

Ce n'est pas vraiment "anormal"  tu peux évidement optimiser le serveur pour avoir un plus gros buffer pour différentes choses, mais la ça va avec la quantitée de ram que tu veux lui dédier...

Par exemple sur un de mes serveurs après 1 jours et 22 heures de fonctionnement j'ai
Created_tmp_disk_tables  29k
Created_tmp_files               64

Created_tmp_tables 574k
Opened_tables
117 k
Open_tables
512

Et le serveur héberge environ 1250 sites, pour un total de plus de 2200 bases de données.

L'erreur 111 peut être causer par beaucoup de choses, pas nécéssairement par le nombre de tables ouvertes...

Il faut aussi savoir après combien de temps tu as ce résultat. (En
effet faut savoir que le résultat est cummulatif, et non les tables
ouvertes en temps réel, puisque c'est au passé CreatED). Et quel usage tu en fais comme demande neige. Si c'est en dev et que ça te fais des erreurs de connexions, alors soit tes scripts sont pourries, soit c'est la machine parce que je doute que tu es 200 connexions simultané en dev et que tu arrives à saturer le socket... Il peut donc s'agire de beaucoup de chose. Partant du simple lague parce que tu lui fais faire une recherche trop intensive jusqu'à la saturation du socket ou au dépassement du nombre de connexion global de mysql...

Pour terminer je dirais BOUHHHH à Ubuntu c'est nul
, mais pour pas faire de débat, je le dirai pas trop fort
Donc désolé mais sans plus de précision (tes scripts et ton usage entre autre) on peut pas trop t'aider..


-------------------
Vous cherchez un hebergement Php/MySQL Gratuit et sans publicités ??
Et bien c'est la : www.e3b.org