Erreur de sécurité sur application vb.net

Résolu
cs_jullebarge Messages postés 2 Date d'inscription dimanche 1 août 2004 Statut Membre Dernière intervention 9 avril 2008 - 8 avril 2008 à 18:07
cs_jullebarge Messages postés 2 Date d'inscription dimanche 1 août 2004 Statut Membre Dernière intervention 9 avril 2008 - 9 avril 2008 à 12:04
Bonjour à tous,

J'ai un petit souci sur un programme que j'ai développé en vb.net

Il fonctionne très bien sur mon poste, mais je l'ai mis en partarge sur le réseau pour qu'il soit utilisé depuis d'autres pc, et je reçois un message d'erreur lors de son utilisation.

Le programme se lance, mais quand je clique sur un bouton qui ouvre normalement une fenêtre de sélection de fichiers, j'obtiens l'erreur suivante

De quoi cela peut-il venir ? Il est conseillé dans le texte de l'erreur de modifier le niveau de sécurité dans l'outil de config du .net framework, mais je n'ai pas cet outil... le framework 2 est pourtant bien installé.

Bref, une piste pour résoudre ce problème ?

3 réponses

cs_casy Messages postés 7741 Date d'inscription mercredi 1 septembre 2004 Statut Membre Dernière intervention 24 septembre 2014 41
8 avril 2008 à 20:47
En effet, il faut autoriser les opérations réseaux dans les règles de sécurités du Framework de chaque poste.

Je ne sais pas si la réponse de Guillaume permet cela.

J'ai rencontré le même problème, il y a quelques temps, voici le thread que j'avais ouvert à l'époque : ici

La solution donné a marché pour moi (à condition d'avoir les droits d'administration necessaires pour le faire, autre problème que je rencontre chez le client).

---- Sevyc64  (alias Casy) ----<hr size="2" width="100%" /># LE PARTAGE EST NOTRE FORCE #    http://aide-office-vba.monforum.com/index.php
3
guillaume1136 Messages postés 21 Date d'inscription jeudi 10 novembre 2005 Statut Membre Dernière intervention 3 juin 2008
8 avril 2008 à 19:38
J'ai peut être une idée...

Si tu utilise Visual Studio 2005 ou 2008,
Regarde dans la fenêtre de propriété de ton projet,
va dans l'onglet sécurité,
coche "Activer les paramètres de sécurité ClickOnce"
puis choisie "Il sagit d'une application a confiance partielle"
puis, dans la liste, inclut tout se qui est en rapport avec le web, ou inclut carrement tout.
Et dis moi si sa marche, car je ne suis pas sur que le problème vienne de ça.

GuiGui
0
cs_jullebarge Messages postés 2 Date d'inscription dimanche 1 août 2004 Statut Membre Dernière intervention 9 avril 2008
9 avril 2008 à 12:04
Merci à vous deux, j'ai trouvé la solution sur le lien que donne Casy, la commande à lancer résoud le souci.
0