OpenProcessToken() ERROR_ACCESS_DENIED [Résolu]

Messages postés
223
Date d'inscription
mercredi 13 juillet 2005
Dernière intervention
8 août 2011
- - Dernière réponse : HeavenForsaker
Messages postés
223
Date d'inscription
mercredi 13 juillet 2005
Dernière intervention
8 août 2011
- 29 mars 2008 à 12:20
Bonjour,

J'ai une erreur lors de l'utilisation de la fonction OpenProcessToken qui se produit uniquement sur XP et sur les processus SERVICE LOCAL, SERVICE RESEAU.

Voici un extrait du code :
-----------------------------------------------------------------------------------------------------------------
SetDebugPrivilege();

hProcess = OpenProcess(PROCESS_QUERY_INFORMATION | PROCESS_VM_READ, 0, dwProcessId);

OpenProcessToken(hProcess, TOKEN_QUERY, &hToken);
-----------------------------------------------------------------------------------------------------------------

OpenProcessToken renvoi ERROR_ACCESS_DENIED uniquement sur les services.

Quelqu'un a une idée ?

++
Afficher la suite 
A voir également:

Votre réponse

1 réponse

Meilleure réponse
Messages postés
223
Date d'inscription
mercredi 13 juillet 2005
Dernière intervention
8 août 2011
3
Merci
WTSEnumerateProcesses()

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 123 internautes nous ont dit merci ce mois-ci

Commenter la réponse de HeavenForsaker

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.