Tomcat install : page blanche sur le localhost:8180 [Résolu]

Fridimette 12 Messages postés mercredi 19 mars 2008Date d'inscription 21 avril 2008 Dernière intervention - 28 mars 2008 à 16:19 - Dernière réponse : Fridimette 12 Messages postés mercredi 19 mars 2008Date d'inscription 21 avril 2008 Dernière intervention
- 31 mars 2008 à 14:58
Bonjour,

J'en suis à (au moins) ma 7ième ré-installation de tomcat et à chaque fois un problème différent apparait.

Je suis même aller demander de l'aide à un de mes profs d'info mais il n'a pas pu m'aider !

Alors svp !! c'est la base sans çà je ne peux pas faire mes pages en jsp !


Voilà le soucis :

1:page blanche quand j'arrive sur la page localhost:8180 !

2: variables d'environnements qui sont définies à chaque démarrage mais
bizarrement quand je tape dans ma console : echo $JAVA_HOME ca me
répond un vide (de même pour Catalina_Home bien entendu)

3: répertoire /usr/share/tomcat5.5/conf/Catalina/localhost vide (donc oui problème de déploiement).


voici mon log :
28 mars 200815:55:43 org.apache.coyote.http11.Http11BaseProtocol pause
INFO: Suspension de Coyote HTTP/1.1 sur http-8180
28 mars 200815:55:43 org.apache.catalina.connector.Connector pause
GRAVE: La suspension du gestionnaire de protocole a échouée
java.lang.NullPointerException
at org.apache.jk.server.JkMain.pause(JkMain.java:679)
at org.apache.jk.server.JkCoyoteHandler.pause(JkCoyoteHandler.java:163)
at org.apache.catalina.connector.Connector.pause(Connector.java:1032)
at org.apache.catalina.core.StandardService.stop(StandardService.java:489)
at org.apache.catalina.core.StandardServer.stop(StandardServer.java:734)
at org.apache.catalina.startup.Catalina.stop(Catalina.java:602)
at org.apache.catalina.startup.Catalina$CatalinaShutdownHook.run(Catalina.java:645)
28 mars 200815:55:44 org.apache.catalina.core.StandardService stop
INFO: Arrêt du service Catalina
28 mars 200815:55:44 org.apache.catalina.connector.MapperListener destroy
ATTENTION: Error unregistering MBeanServerDelegate
java.lang.NullPointerException
at org.apache.catalina.connector.MapperListener.destroy(MapperListener.java:162)
at org.apache.catalina.connector.Connector.stop(Connector.java:1138)
at org.apache.catalina.core.StandardService.stop(StandardService.java:519)
at org.apache.catalina.core.StandardServer.stop(StandardServer.java:734)
at org.apache.catalina.startup.Catalina.stop(Catalina.java:602)
at org.apache.catalina.startup.Catalina$CatalinaShutdownHook.run(Catalina.java:645)
28 mars 200815:55:44 org.apache.coyote.http11.Http11BaseProtocol destroy
INFO: Arrêt de Coyote HTTP/1.1 sur http-8180
28 mars 200815:55:44 org.apache.catalina.connector.Connector stop
GRAVE: Le connecteur Coyote n'a pas été démarré
28 mars 2008 15:55:44 org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: Failed shutdown of Apache Portable Runtime
fripette@coccigrue:/usr/share/tomcat5.5/logs$

Je viens de faire une tentative de restart:

4:

coccigrue:/etc/init.d# ./tomcat5.5 restart

Stopping Tomcat servlet engine: tomcat5.5.

Starting Tomcat servlet engine: tomcat5.5.


et dans les logs pas d'actualisation !


J'en ai un peu marre de tomcat : vous n'auriez pas une autre solution pour déployer des jsp/servlets ?


de l'aide s'il vous plait ca fait un mois que je suis sure ca !

Merci
Afficher la suite 

5 réponses

Répondre au sujet
cs_AlexN 719 Messages postés lundi 5 décembre 2005Date d'inscription 8 janvier 2014 Dernière intervention - 31 mars 2008 à 13:42
+3
Utile
Salut,

Soit il s'agit d'une erreur de copier-coller, soit autre chose mais le fichier de configuration est erroné : il n'y a pas de balise fermante pour <service>

D'autre part cette balise est incomplète. Il y a plusieurs connecteurs mais aucune définition d'unités de traitement (engine, host...). Il faut terminer la configuration avec quelquechose comme :

  <Engine name="Catalina" defaultHost="localhost" debug="0">
    <Host name="localhost" debug="0" appBase="webapps"
       unpackWARs="true" autoDeploy="true"
       xmlValidation="false" xmlNamespaceAware="false">
    </Host>
  </Engine>
</Service>

Enfin après il faut consulter la documentation pour les paramètres spécifiques à ton contexte.

Tu peux également spécifier le protocole du connecteur sur 8180 (protocol="HTTP/1.1") comme dans la déclaration du connecteur AJP. Enlèves également les connecteurs dont tu n'as pas besoin.

pour avoir les logs, il faut :

- ajouter l'attribut debug=valeur à la balise <Server>, avec valeur > = 1
- Ajouter un logger dans ton engine

<Logger className="org.apache.catalina.logger.FileLogger"
              prefix="catalina_log." suffix=".txt"
              timestamp="true"/>
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de cs_AlexN
chat11 58 Messages postés lundi 10 septembre 2007Date d'inscription 12 février 2011 Dernière intervention - 28 mars 2008 à 17:04
0
Utile
tu utilise quoi comme éditeur? et est ce que lors de l'installation tu a mis le n° de port 8180?
Commenter la réponse de chat11
Fridimette 12 Messages postés mercredi 19 mars 2008Date d'inscription 21 avril 2008 Dernière intervention - 28 mars 2008 à 17:13
0
Utile
MERCI de ta réponse
Editeur : Eclipse
OS: Linux Debian
Port : non je n'ai rien spécifié par rapport au port je pense que par défaut il se rabat sur 8180 si 8080 n'est pas libre.
De plus lorsque j'arrive sur mon localhost:8180 j'ai l'avatar de tomcat dans ma barre d'adresse
Voici mon cat de server.xml (situé dans le répertoire conf)

cat server.xml
<!-- Server Configuration File for Tomcat 5.5 on Debian
     You can find a more complete example in /usr/share/doc/tomcat5.5/examples/
 -->

<!-- Note that component elements are nested corresponding to their
     parent-child relationships with each other -->

<!-- A "Server" is a singleton element that represents the entire JVM,
     which may contain one or more "Service" instances.  The Server
     listens for a shutdown command on the indicated port.

     Note:  A "Server" is not itself a "Container", so you may not
     define subcomponents such as "Valves" or "Loggers" at this level.
 -->

<Server port="8005" shutdown="SHUTDOWN">

  <!-- Comment these entries out to disable JMX MBeans support used for the
       administration web application -->
  <Listener className="org.apache.catalina.core.AprLifecycleListener" />
  <Listener className="org.apache.catalina.mbeans.ServerLifecycleListener" />
  <Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener" />
  <Listener className="org.apache.catalina.storeconfig.StoreConfigLifecycleListener"/>

  <!-- Global JNDI resources -->
  <GlobalNamingResources>

    <!-- Test entry for demonstration purposes -->
    <Environment name="simpleValue" type="java.lang.Integer" value="30"/>

    <!-- Editable user database that can also be used by
         UserDatabaseRealm to authenticate users -->
    <Resource name="UserDatabase" auth="Container"
              type="org.apache.catalina.UserDatabase"
       description="User database that can be updated and saved"
           factory="org.apache.catalina.users.MemoryUserDatabaseFactory"
          pathname="conf/tomcat-users.xml" />

  </GlobalNamingResources>

  <!-- A "Service" is a collection of one or more "Connectors" that share
       a single "Container" (and therefore the web applications visible
       within that Container).  Normally, that Container is an "Engine",
       but this is not required.

       Note:  A "Service" is not itself a "Container", so you may not
       define subcomponents such as "Valves" or "Loggers" at this level.
   -->

  <!-- Define the Tomcat Stand-Alone Service -->
  <Service name="Catalina">

    <!-- A "Connector" represents an endpoint by which requests are received
         and responses are returned.  Each Connector passes requests on to the
         associated "Container" (normally an Engine) for processing.

         By default, a non-SSL HTTP/1.1 Connector is established on port 8180.
         You can also enable an SSL HTTP/1.1 Connector on port 8443 by
         following the instructions below and uncommenting the second Connector
         entry.  SSL support requires the following steps (see the SSL Config
         HOWTO in the Tomcat 5 documentation bundle for more detailed
         instructions):
         * If your JDK version 1.3 or prior, download and install JSSE 1.0.2 or
           later, and put the JAR files into "$JAVA_HOME/jre/lib/ext".
         * Execute:
             %JAVA_HOME%\bin\keytool -genkey -alias tomcat -keyalg RSA (Windows)
             $JAVA_HOME/bin/keytool -genkey -alias tomcat -keyalg RSA  (Unix)
           with a password value of "changeit" for both the certificate and
           the keystore itself.

         By default, DNS lookups are enabled when a web application calls
         request.getRemoteHost().  This can have an adverse impact on
         performance, so you can disable it by setting the
         "enableLookups" attribute to "false".  When DNS lookups are disabled,
         request.getRemoteHost() will return the String version of the
         IP address of the remote client.
    -->

    <!-- Define a non-SSL HTTP/1.1 Connector on port 8180 -->
    <Connector port="8180" maxHttpHeaderSize="8192"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" redirectPort="8443" acceptCount="100"
               connectionTimeout="20000" disableUploadTimeout="true" />
    <!-- Note : To disable connection timeouts, set connectionTimeout value
     to 0 -->
   
    <!-- Note : To use gzip compression you could set the following properties :
   
               compression="on"
               compressionMinSize="2048"
               noCompressionUserAgents="gozilla, traviata"
               compressableMimeType="text/html,text/xml"
    -->

    <!-- Define a SSL HTTP/1.1 Connector on port 8443 -->
    <!--
    <Connector port="8443" maxHttpHeaderSize="8192"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" disableUploadTimeout="true"
               acceptCount="100" scheme="https" secure="true"
               clientAuth="false" sslProtocol="TLS" />
    -->

    <!-- Define an AJP 1.3 Connector on port 8009 -->
    <Connector port="8009"
               enableLookups="false" redirectPort="8443" protocol="AJP/1.3" />

    <!-- Define a Proxied HTTP/1.1 Connector on port 8082 -->
    <!-- See proxy documentation for more information about using this. -->
    <!--
    <Connector port="8082"
               maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
               enableLookups="false" acceptCount="100" connectionTimeout="20000"
               proxyPort="80" disableUploadTimeout="true" />
    -->
Commenter la réponse de Fridimette
chat11 58 Messages postés lundi 10 septembre 2007Date d'inscription 12 février 2011 Dernière intervention - 28 mars 2008 à 22:57
0
Utile
désolé ,je ne travaille pas sous linux, j'ai aimé de t'aider , vraiment désolé
Commenter la réponse de chat11
Fridimette 12 Messages postés mercredi 19 mars 2008Date d'inscription 21 avril 2008 Dernière intervention - 31 mars 2008 à 14:58
0
Utile
Effectivement il y avait pleins de lacunes dans mes fichiers de configuration donc j'ai tout purgé et maintenant tout marche (avec les fichiers par défaut).
J'ai un autre soucis mais je vais ouvrir sujet à ce propos.
Merci pour ton aide !!
Commenter la réponse de Fridimette

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.