Problème avec des ListeView (C#)

Signaler
Messages postés
4
Date d'inscription
mercredi 19 février 2003
Statut
Membre
Dernière intervention
26 mars 2003
-
Messages postés
4
Date d'inscription
mercredi 19 février 2003
Statut
Membre
Dernière intervention
26 mars 2003
-
Je n'arrive pas à afficher les SubItem.
je fais:

ListViewItem liste = new ListViewItem(new string[]{"aa" , "bb" , "cc"});
lv.Items.Add(liste);

(lv est une listeView)

à l'affichage il n'y a que:
aa

et pas le reste. Pourquoi?
qu'est-ce qu'il faut faire pour que ca marche et affiche:
aa bb cc

Merci d'avance

J'aime les plans qui se déroulent sans embrouille 8-)

Zaecken

2 réponses

Messages postés
9
Date d'inscription
mercredi 11 octobre 2000
Statut
Membre
Dernière intervention
23 juillet 2003

Je supose qu'il doit manquer qq initialisations dans ton code.

//Pour afficher la ListView en mode détails
lv.View = View.Details;

//La ListView se découpe ici en trois colonnes
lv.Columns.Add("txt1", 100, HorizontalAlignment.Center);
lv.Columns.Add("txt2", 100, HorizontalAlignment.Center);
lv.Columns.Add("txt2", 100, HorizontalAlignment.Center);
//Le premier paramètre est le texte de 'entête de colonne
//Le second est la largeur de la colone (ici 100 pxl)
//Le troisième est l'alignement des données ds la colonne

Je pense que ton problème vient de là.
Si ce n'est pas la cas je ne vois pas la solution.
Messages postés
4
Date d'inscription
mercredi 19 février 2003
Statut
Membre
Dernière intervention
26 mars 2003

Merci pour ta réponse, ca marche maintenant

@+